summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:24:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:24:19 +0000
commit12a9d6a0f2cad6129f9423ecc4d08744f13e7023 (patch)
treebd0e203bc788e81799bae1d5adaab781a99a0251 /dev-python/scimath
parentEAPI bump (diff)
downloadhistorical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.tar.gz
historical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.tar.bz2
historical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.zip
Version bump
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-python/scimath')
-rw-r--r--dev-python/scimath/ChangeLog9
-rw-r--r--dev-python/scimath/scimath-4.0.1.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/scimath/ChangeLog b/dev-python/scimath/ChangeLog
index e9ef15b9788c..c5a5729070f1 100644
--- a/dev-python/scimath/ChangeLog
+++ b/dev-python/scimath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/scimath
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.9 2011/08/03 23:54:04 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.10 2012/01/17 06:23:50 bicatali Exp $
+
+*scimath-4.0.1 (17 Jan 2012)
+
+ 17 Jan 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> +scimath-4.0.1.ebuild:
+ Version bump
*scimath-4.0.0 (03 Aug 2011)
diff --git a/dev-python/scimath/scimath-4.0.1.ebuild b/dev-python/scimath/scimath-4.0.1.ebuild
new file mode 100644
index 000000000000..7d158a84de9b
--- /dev/null
+++ b/dev-python/scimath/scimath-4.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.0.1.ebuild,v 1.1 2012/01/17 06:23:50 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
+HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/traits-4.1
+ >=dev-python/traitsui-4.1
+ sci-libs/scipy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+}