summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-11-09 11:01:25 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-11-09 11:01:25 +0000
commit2cc787d7fe9d4863b98886a6104551360903915b (patch)
tree530fccfdca4d53f805fbc2ec3c39f65af323fcc3 /dev-python/simplegui/simplegui-0.1.0.ebuild
parentdev-python/mpi4py: Version BUmp (diff)
downloadhistorical-2cc787d7fe9d4863b98886a6104551360903915b.tar.gz
historical-2cc787d7fe9d4863b98886a6104551360903915b.tar.bz2
historical-2cc787d7fe9d4863b98886a6104551360903915b.zip
add python3_2 and python3_3 wrt #487412
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0xE73C35B3
Diffstat (limited to 'dev-python/simplegui/simplegui-0.1.0.ebuild')
-rw-r--r--dev-python/simplegui/simplegui-0.1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/simplegui/simplegui-0.1.0.ebuild b/dev-python/simplegui/simplegui-0.1.0.ebuild
index 7a95fa0d2073..b88b70437326 100644
--- a/dev-python/simplegui/simplegui-0.1.0.ebuild
+++ b/dev-python/simplegui/simplegui-0.1.0.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplegui/simplegui-0.1.0.ebuild,v 1.1 2013/10/08 20:35:16 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplegui/simplegui-0.1.0.ebuild,v 1.2 2013/11/09 11:01:20 hasufell Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
PYTHON_REQ_USE="tk"
+DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -20,3 +21,11 @@ IUSE=""
DEPEND="app-arch/unzip
dev-python/cx_Freeze[${PYTHON_USEDEP}]"
+
+python_compile() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 --no-diffs -w *.py || die
+ fi
+
+ distutils-r1_python_compile
+}