summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-05-21 07:16:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-05-21 07:16:34 +0000
commitf0b0ead48c9d30e58252d8f92a0a7bc61e219480 (patch)
treeb835f2d4c41755c6069cf73acfdb18230e9c07b2 /dev-python/simplejson
parentSynchronize ebuild for 2.2.0 with 2.4.1; convert forced gnome-extra/yelp runt... (diff)
downloadhistorical-f0b0ead48c9d30e58252d8f92a0a7bc61e219480.tar.gz
historical-f0b0ead48c9d30e58252d8f92a0a7bc61e219480.tar.bz2
historical-f0b0ead48c9d30e58252d8f92a0a7bc61e219480.zip
Bump for #416801
Package-Manager: portage-2.2.0_alpha107/cvs/Linux x86_64
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-2.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 730c18f990d0..6301b50b9194 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.64 2012/05/18 05:51:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.65 2012/05/21 07:16:34 patrick Exp $
+
+*simplejson-2.5.2 (21 May 2012)
+
+ 21 May 2012; Patrick Lauer <patrick@gentoo.org> +simplejson-2.5.2.ebuild:
+ Bump for #416801
18 May 2012; Jeff Horelick <jdhore@gentoo.org> simplejson-2.5.0.ebuild:
marked x86 per bug 415881
diff --git a/dev-python/simplejson/simplejson-2.5.2.ebuild b/dev-python/simplejson/simplejson-2.5.2.ebuild
new file mode 100644
index 000000000000..3f8215d18656
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.5.2.ebuild,v 1.1 2012/05/21 07:16:34 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_test() {
+ testing() {
+ if [[ "$(python_get_implementation)" != "Jython" ]]; then
+ ln -fs ../$(ls -d build-${PYTHON_ABI}/lib*)/simplejson/_speedups.so simplejson/_speedups.so || return 1
+ fi
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/simplejson/tests"
+ }
+ python_execute_function -q delete_tests
+}