summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-30 08:28:47 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-30 08:28:47 +0000
commit2f3b8ac0b67606d5da22f951722ff4f09c43120f (patch)
tree4bdca73c54ae5202799170f0f0becac226878587 /dev-python/starcluster/files/starcluster-0.93.3-requires.patch
parentFix typo in ChangeLog (diff)
downloadhistorical-2f3b8ac0b67606d5da22f951722ff4f09c43120f.tar.gz
historical-2f3b8ac0b67606d5da22f951722ff4f09c43120f.tar.bz2
historical-2f3b8ac0b67606d5da22f951722ff4f09c43120f.zip
Replacement -requires.patch, thanks to initial ebuild author J. T. Riley, fixes Bug #437912
Package-Manager: portage-2.1.11.30/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/starcluster/files/starcluster-0.93.3-requires.patch')
-rw-r--r--dev-python/starcluster/files/starcluster-0.93.3-requires.patch33
1 files changed, 19 insertions, 14 deletions
diff --git a/dev-python/starcluster/files/starcluster-0.93.3-requires.patch b/dev-python/starcluster/files/starcluster-0.93.3-requires.patch
index 2674b867a33e..fb3f284ecb7a 100644
--- a/dev-python/starcluster/files/starcluster-0.93.3-requires.patch
+++ b/dev-python/starcluster/files/starcluster-0.93.3-requires.patch
@@ -1,14 +1,19 @@
-diff -ur StarCluster-0.93.3.orig/StarCluster.egg-info/requires.txt StarCluster-0.93.3/StarCluster.egg-info/requires.txt
---- StarCluster.egg-info/requires.txt 2012-03-21 10:02:45.000000000 +0800
-+++ StarCluster.egg-info/requires.txt 2012-11-14 06:57:29.319441881 +0800
-@@ -1,6 +1,6 @@
--ssh==1.7.13
--boto==2.3.0
-+ssh>=1.7.13
-+boto>=2.3.0
- workerpool==0.9.2
- Jinja2==2.6
- decorator==3.3.1
--pyasn1==0.0.13b
-\ No newline at end of file
-+pyasn1>=0.0.13b
+Patch by JT Riley, Bug #437912
+diff --git a/setup.py b/setup.py
+index 241b7ce..3c52c68 100644
+--- a/setup.py
++++ b/setup.py
+@@ -12,9 +12,9 @@ try:
+ console_scripts = ['starcluster = starcluster.cli:main']
+ extra = dict(test_suite="starcluster.tests",
+ tests_require="nose",
+- install_requires=["ssh==1.7.13", "boto==2.3.0",
+- "workerpool==0.9.2", "Jinja2==2.6",
+- "decorator==3.3.1", "pyasn1==0.0.13b"],
++ install_requires=["ssh>=1.7.13", "boto>=2.3.0",
++ "workerpool>=0.9.2", "Jinja2>=2.6",
++ "decorator>=3.3.1", "pyasn1>=0.0.13b"],
+ include_package_data=True,
+ entry_points=dict(console_scripts=console_scripts),
+ zip_safe=False)
+