summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-05-01 22:52:29 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-05-01 22:52:29 +0000
commit40edb3752bffff02afc85ed1000c99ec36092d1f (patch)
tree1d74618c52d6ac3fd82c771e0f72a8048542e609 /dev-python/tpg/tpg-3.0.2.ebuild
parentVersion bump, bug #49610. (diff)
downloadhistorical-40edb3752bffff02afc85ed1000c99ec36092d1f.tar.gz
historical-40edb3752bffff02afc85ed1000c99ec36092d1f.tar.bz2
historical-40edb3752bffff02afc85ed1000c99ec36092d1f.zip
Initial import, bug #48538.
Diffstat (limited to 'dev-python/tpg/tpg-3.0.2.ebuild')
-rw-r--r--dev-python/tpg/tpg-3.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/tpg/tpg-3.0.2.ebuild b/dev-python/tpg/tpg-3.0.2.ebuild
new file mode 100644
index 000000000000..835c38c1cad3
--- /dev/null
+++ b/dev-python/tpg/tpg-3.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/tpg-3.0.2.ebuild,v 1.1 2004/05/01 22:52:29 kloeri Exp $
+
+inherit distutils
+
+MY_P="TPG-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Toy Parser Generator for Python"
+HOMEPAGE="http://christophe.delord.free.fr/en/tpg/"
+SRC_URI="http://christophe.delord.free.fr/soft/tpg/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/python"
+
+DOCS="License.txt THANKS"
+
+src_install() {
+ distutils_src_install
+ use doc && ( dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* )
+}