summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-09-27 18:17:04 +0000
committerMarien Zwart <marienz@gentoo.org>2012-09-27 18:17:04 +0000
commitcbf7e5b262411a1ef259576bdbedbe25dc8ab0b2 (patch)
tree6d7a88dcc5fe8dae03f323f3800a845f75e07044 /dev-python/twisted-news
parentBump to 12.2.0 (bug #423777) with some test-related ebuild improvements. (diff)
downloadhistorical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.tar.gz
historical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.tar.bz2
historical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.zip
Bump to 12.2.0 (bug #423789)
Package-Manager: portage-2.2.0_alpha133/cvs/Linux x86_64
Diffstat (limited to 'dev-python/twisted-news')
-rw-r--r--dev-python/twisted-news/ChangeLog8
-rw-r--r--dev-python/twisted-news/twisted-news-12.2.0.ebuild22
2 files changed, 28 insertions, 2 deletions
diff --git a/dev-python/twisted-news/ChangeLog b/dev-python/twisted-news/ChangeLog
index 30570a1bc614..fb42a82d50a6 100644
--- a/dev-python/twisted-news/ChangeLog
+++ b/dev-python/twisted-news/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-news
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.55 2012/03/22 07:06:57 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.56 2012/09/27 18:17:04 marienz Exp $
+
+*twisted-news-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-news-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-news-12.0.0 (22 Mar 2012)
@@ -217,4 +222,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-news-0.1.0:
initial import
twisted-news was part of the main twisted release
-
diff --git a/dev-python/twisted-news/twisted-news-12.2.0.ebuild b/dev-python/twisted-news/twisted-news-12.2.0.ebuild
new file mode 100644
index 000000000000..8f753ff9b090
--- /dev/null
+++ b/dev-python/twisted-news/twisted-news-12.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-12.2.0.ebuild,v 1.1 2012/09/27 18:17:04 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="News"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted News is an NNTP server and programming library."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ =dev-python/twisted-mail-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/news twisted/plugins"