summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-12 21:41:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-12 21:41:24 +0000
commit5b7dc0aecae2b8b37d3cf0442f8104ecde96bdfc (patch)
tree728e413d2138b4a8a79dfbea8289cccc30c53ed0 /dev-python/unittest2/unittest2-0.5.1.ebuild
parentOld. (diff)
downloadhistorical-5b7dc0aecae2b8b37d3cf0442f8104ecde96bdfc.tar.gz
historical-5b7dc0aecae2b8b37d3cf0442f8104ecde96bdfc.tar.bz2
historical-5b7dc0aecae2b8b37d3cf0442f8104ecde96bdfc.zip
Version bump.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/unittest2/unittest2-0.5.1.ebuild')
-rw-r--r--dev-python/unittest2/unittest2-0.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/unittest2/unittest2-0.5.1.ebuild b/dev-python/unittest2/unittest2-0.5.1.ebuild
new file mode 100644
index 000000000000..1f7256ae02d3
--- /dev/null
+++ b/dev-python/unittest2/unittest2-0.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.5.1.ebuild,v 1.1 2010/07/12 21:41:24 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="The new features in unittest for Python 2.7 backported to Python 2.4+."
+HOMEPAGE="http://pypi.python.org/pypi/unittest2"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="README.txt"
+
+src_test() {
+ testing() {
+ ./unit2 discover
+ }
+ python_execute_function testing
+}