summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-13 18:59:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-13 18:59:15 +0000
commit5a47c1c55b06b08bf67dedc8c5736a62f934608b (patch)
tree45d03a9ea687a5bd68041018a783da46881e0fe9 /dev-python/webut/webut-0.1.0.2.ebuild
parentamd64 stable, bug 309167 (diff)
downloadhistorical-5a47c1c55b06b08bf67dedc8c5736a62f934608b.tar.gz
historical-5a47c1c55b06b08bf67dedc8c5736a62f934608b.tar.bz2
historical-5a47c1c55b06b08bf67dedc8c5736a62f934608b.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-15825-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/webut/webut-0.1.0.2.ebuild')
-rw-r--r--dev-python/webut/webut-0.1.0.2.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/dev-python/webut/webut-0.1.0.2.ebuild b/dev-python/webut/webut-0.1.0.2.ebuild
index acc67d0f5204..6922539c7f91 100644
--- a/dev-python/webut/webut-0.1.0.2.ebuild
+++ b/dev-python/webut/webut-0.1.0.2.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webut/webut-0.1.0.2.ebuild,v 1.11 2009/11/25 22:14:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webut/webut-0.1.0.2.ebuild,v 1.12 2010/03/13 18:59:15 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils versionator
@@ -9,15 +13,17 @@ MY_P=${PN}_$(replace_version_separator 2 '-')
DESCRIPTION="Miscellaneous utilities for nevow and twisted.web programming"
HOMEPAGE="http://www.inoi.fi/open/trac/webut"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
IUSE="examples"
-DEPEND=""
-RDEPEND=">=dev-python/twisted-2
- >=net-zope/zope-interface-3.0.1
- >=dev-python/nevow-0.9.18"
+RDEPEND=">=dev-python/nevow-0.9.18
+ >=dev-python/twisted-2
+ >=net-zope/zope-interface-3.0.1"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"