summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-10 23:30:15 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-10 23:30:15 +0000
commit8162b003d5afd9f7e9eaf32090151e7a0482851b (patch)
tree9063634280973a5be567e20afb933b5427a94dc1 /dev-python/wxPython
parentAF_UNIX and process title support. (diff)
downloadhistorical-8162b003d5afd9f7e9eaf32090151e7a0482851b.tar.gz
historical-8162b003d5afd9f7e9eaf32090151e7a0482851b.tar.bz2
historical-8162b003d5afd9f7e9eaf32090151e7a0482851b.zip
fixed a typo in controls2.py
Diffstat (limited to 'dev-python/wxPython')
-rw-r--r--dev-python/wxPython/ChangeLog6
-rw-r--r--dev-python/wxPython/Manifest5
-rw-r--r--dev-python/wxPython/files/controls2.py.patch36
-rw-r--r--dev-python/wxPython/wxPython-2.4.1.2.ebuild10
4 files changed, 53 insertions, 4 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 6539e9c47a51..38f94ff5553d 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.28 2003/07/09 01:00:47 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.29 2003/07/10 23:30:15 raker Exp $
+
+ 10 Jul 2003; Nick Hadaway <raker@gentoo.org> wxPython-2.4.1.2.ebuild,
+ files/controls2.py.patch:
+ Added a tiny patch to fix a typo in controls2.py
*wxPython-2.4.1.2 (09 Jul 2003)
diff --git a/dev-python/wxPython/Manifest b/dev-python/wxPython/Manifest
index 976be4e4afc8..631118942696 100644
--- a/dev-python/wxPython/Manifest
+++ b/dev-python/wxPython/Manifest
@@ -1,6 +1,7 @@
-MD5 f8fadd26961c1f96a9a1009f9cd72ff2 ChangeLog 4425
MD5 028027d2871c90469b2f389475c25a30 wxPython-2.4.0.7.ebuild 3117
-MD5 2ce81dd01f8567e67f319b8754f82c2b wxPython-2.4.1.2.ebuild 2986
+MD5 69ea1c9f4eb815a226e390126b41a49d wxPython-2.4.1.2.ebuild 3081
+MD5 013db1dbe8cad69b833829d6ce273d8b ChangeLog 4577
MD5 3b06f1e87549af51d78bb7bfa33728b5 metadata.xml 182
MD5 88f72c81ee2c594876b3bddc9e14bb72 files/digest-wxPython-2.4.0.7 73
MD5 ce3003c042f7c8fe4700193e357ad2ad files/digest-wxPython-2.4.1.2 73
+MD5 99504d777b11bc0266e7487ee59496dd files/controls2.py.patch 2202
diff --git a/dev-python/wxPython/files/controls2.py.patch b/dev-python/wxPython/files/controls2.py.patch
new file mode 100644
index 000000000000..82ce09776a10
--- /dev/null
+++ b/dev-python/wxPython/files/controls2.py.patch
@@ -0,0 +1,36 @@
+diff -urN wxPythonSrc-2.4.1.2/wxPython/src/gtk/controls2.py wxPythonSrc-2.4.1.2-modified/wxPython/src/gtk/controls2.py
+--- wxPythonSrc-2.4.1.2/wxPython/src/gtk/controls2.py 2003-06-12 18:25:30.000000000 -0500
++++ wxPythonSrc-2.4.1.2-modified/wxPython/src/gtk/controls2.py 2003-07-10 18:19:51.000000000 -0500
+@@ -642,7 +642,7 @@
+ return "<%s.%s instance; proxy of C++ wxListCtrl instance at %s>" % (self.__class__.__module__, self.__class__.__name__, self.this)
+
+ def GetColumn(self, *_args, **_kwargs):
+- val = ontrols2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
++ val = controls2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
+ if val is not None: val.thisown = 1
+ return val
+
+diff -urN wxPythonSrc-2.4.1.2/wxPython/src/mac/controls2.py wxPythonSrc-2.4.1.2-modified/wxPython/src/mac/controls2.py
+--- wxPythonSrc-2.4.1.2/wxPython/src/mac/controls2.py 2003-05-16 13:36:52.000000000 -0500
++++ wxPythonSrc-2.4.1.2-modified/wxPython/src/mac/controls2.py 2003-07-10 18:20:41.000000000 -0500
+@@ -642,7 +642,7 @@
+ return "<%s.%s instance; proxy of C++ wxListCtrl instance at %s>" % (self.__class__.__module__, self.__class__.__name__, self.this)
+
+ def GetColumn(self, *_args, **_kwargs):
+- val = ontrols2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
++ val = controls2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
+ if val is not None: val.thisown = 1
+ return val
+
+diff -urN wxPythonSrc-2.4.1.2/wxPython/src/msw/controls2.py wxPythonSrc-2.4.1.2-modified/wxPython/src/msw/controls2.py
+--- wxPythonSrc-2.4.1.2/wxPython/src/msw/controls2.py 2003-05-07 14:29:04.000000000 -0500
++++ wxPythonSrc-2.4.1.2-modified/wxPython/src/msw/controls2.py 2003-07-10 18:20:11.000000000 -0500
+@@ -645,7 +645,7 @@
+ return "<%s.%s instance; proxy of C++ wxListCtrl instance at %s>" % (self.__class__.__module__, self.__class__.__name__, self.this)
+
+ def GetColumn(self, *_args, **_kwargs):
+- val = ontrols2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
++ val = controls2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
+ if val is not None: val.thisown = 1
+ return val
+
diff --git a/dev-python/wxPython/wxPython-2.4.1.2.ebuild b/dev-python/wxPython/wxPython-2.4.1.2.ebuild
index 98bec88f6a2b..42122cf0df09 100644
--- a/dev-python/wxPython/wxPython-2.4.1.2.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.1.2.ebuild,v 1.1 2003/07/09 01:00:47 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.1.2.ebuild,v 1.2 2003/07/10 23:30:15 raker Exp $
+
+inherit eutils
IUSE="opengl gtk2"
@@ -39,6 +41,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/controls2.py.patch
+}
+
src_compile() {
# create links so the build doesnt fail
#for d in ogl stc xrc gizmos ; do