summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-07-17 00:46:08 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-07-17 00:46:08 +0000
commitf9f6af66e1f4562dbc52bbaf1c6cd1ab6188e142 (patch)
tree118f4fb939d40351f485d35665f70cbb4fe22872 /dev-python/yolk/yolk-0.3.0.ebuild
parentbump to 2.18.3, fix some memory leaks (diff)
downloadhistorical-f9f6af66e1f4562dbc52bbaf1c6cd1ab6188e142.tar.gz
historical-f9f6af66e1f4562dbc52bbaf1c6cd1ab6188e142.tar.bz2
historical-f9f6af66e1f4562dbc52bbaf1c6cd1ab6188e142.zip
Version bump. Removed obsolete version.
Package-Manager: portage-2.1.3_rc8
Diffstat (limited to 'dev-python/yolk/yolk-0.3.0.ebuild')
-rw-r--r--dev-python/yolk/yolk-0.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/yolk/yolk-0.3.0.ebuild b/dev-python/yolk/yolk-0.3.0.ebuild
new file mode 100644
index 000000000000..9e8d932928a0
--- /dev/null
+++ b/dev-python/yolk/yolk-0.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/yolk-0.3.0.ebuild,v 1.1 2007/07/17 00:46:08 pythonhead Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Tool and library for querying PyPI and locally installed Python packages"
+HOMEPAGE="http://cheeseshop.python.org/pypi/yolk"
+SRC_URI="http://cheeseshop.python.org/packages/source/y/yolk/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}
+ dev-python/yolk-portage"
+
+
+src_install() {
+ distutils_src_install
+ if use examples ; then
+ docinto examples/plugins
+ dodoc ${S}/examples/plugins/*
+ docinto examples/plugins/yolk_portage
+ dodoc ${S}/examples/plugins/yolk_portage/*
+ docinto examples/plugins/yolk_pkg_manager
+ dodoc ${S}/examples/plugins/yolk_pkg_manager/*
+ prepalldocs
+ fi
+}
+