summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-29 06:21:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-29 06:21:34 +0000
commit37451b75ca199f0797d0c2c08545081dff3401a9 (patch)
tree536d5675486cbc1cd2f92ce0bb2b557edd962bf9 /dev-python
parentBump (diff)
downloadhistorical-37451b75ca199f0797d0c2c08545081dff3401a9.tar.gz
historical-37451b75ca199f0797d0c2c08545081dff3401a9.tar.bz2
historical-37451b75ca199f0797d0c2c08545081dff3401a9.zip
Bump
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyodbc/ChangeLog8
-rw-r--r--dev-python/pyodbc/pyodbc-3.0.6.ebuild27
-rw-r--r--dev-python/python-distutils-extra/ChangeLog9
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.19.ebuild48
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.29.ebuild49
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.34.ebuild (renamed from dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild)2
-rw-r--r--dev-python/python-ldap/ChangeLog7
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.10.ebuild79
8 files changed, 127 insertions, 102 deletions
diff --git a/dev-python/pyodbc/ChangeLog b/dev-python/pyodbc/ChangeLog
index 8174e57d7ba3..1798ba2f9bc3 100644
--- a/dev-python/pyodbc/ChangeLog
+++ b/dev-python/pyodbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyodbc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyodbc/ChangeLog,v 1.4 2012/04/14 11:25:13 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyodbc/ChangeLog,v 1.5 2012/08/29 06:14:58 patrick Exp $
+
+*pyodbc-3.0.6 (29 Aug 2012)
+
+ 29 Aug 2012; Patrick Lauer <patrick@gentoo.org> +pyodbc-3.0.6.ebuild:
+ Bump
*pyodbc-3.0.3 (14 Apr 2012)
@@ -22,4 +27,3 @@
25 Mar 2011; Jesus Rivero <neurogeek@gentoo.org> +pyodbc-2.1.8.ebuild,
+metadata.xml:
Initial commit. Closes bug #230553
-
diff --git a/dev-python/pyodbc/pyodbc-3.0.6.ebuild b/dev-python/pyodbc/pyodbc-3.0.6.ebuild
new file mode 100644
index 000000000000..a1390b68baf7
--- /dev/null
+++ b/dev-python/pyodbc/pyodbc-3.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyodbc/pyodbc-3.0.6.ebuild,v 1.1 2012/08/29 06:14:58 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-* 2.5"
+
+inherit distutils eutils
+
+DESCRIPTION="python ODBC module to connect to almost any database"
+HOMEPAGE="http://code.google.com/p/pyodbc"
+SRC_URI="http://pyodbc.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mssql"
+
+RDEPEND=">=dev-db/unixODBC-2.3.0
+ mssql? ( >=dev-db/freetds-0.64[odbc] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+PYTHON_CXXFLAGS=("* + -fno-strict-aliasing")
+
diff --git a/dev-python/python-distutils-extra/ChangeLog b/dev-python/python-distutils-extra/ChangeLog
index fce35fd914d6..827604ed1e1e 100644
--- a/dev-python/python-distutils-extra/ChangeLog
+++ b/dev-python/python-distutils-extra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-distutils-extra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.12 2012/06/28 07:15:04 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.13 2012/08/29 06:17:05 patrick Exp $
+
+*python-distutils-extra-2.34 (29 Aug 2012)
+
+ 29 Aug 2012; Patrick Lauer <patrick@gentoo.org>
+ +python-distutils-extra-2.34.ebuild, -python-distutils-extra-2.19.ebuild,
+ -python-distutils-extra-2.29.ebuild, -python-distutils-extra-2.32.ebuild:
+ Bump
*python-distutils-extra-2.33 (28 Jun 2012)
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.19.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.19.ebuild
deleted file mode 100644
index a48f5e8d997d..000000000000
--- a/dev-python/python-distutils-extra/python-distutils-extra-2.19.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.19.ebuild,v 1.1 2010/07/15 17:31:57 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="You can integrate gettext support, themed icons and scrollkeeper based documentation in distutils."
-HOMEPAGE="https://launchpad.net/python-distutils-extra"
-SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/dist-${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-# Tests are broken.
-RESTRICT="test"
-
-DOCS="doc/FAQ doc/README doc/setup.cfg.example doc/setup.py.example"
-PYTHON_MODNAME="DistUtilsExtra"
-
-src_prepare() {
- # Disable broken tests.
- sed \
- -e "s/test_desktop/_&/" \
- -e "s/test_policykit/_&/" \
- -e "s/test_requires_provides/_&/" \
- -i test/auto.py || die "sed failed"
-}
-
-src_test() {
- # 5 tests fail with disabled byte-compilation.
- python_enable_pyc
-
- testing() {
- "$(PYTHON)" test/auto.py
- }
- python_execute_function testing
-
- python_disable_pyc
-}
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.29.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.29.ebuild
deleted file mode 100644
index 1a852f6e49bb..000000000000
--- a/dev-python/python-distutils-extra/python-distutils-extra-2.29.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.29.ebuild,v 1.1 2011/12/26 12:11:25 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="You can integrate gettext support, themed icons and scrollkeeper based documentation in distutils."
-HOMEPAGE="https://launchpad.net/python-distutils-extra"
-SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-DOCS="doc/FAQ doc/README doc/setup.cfg.example doc/setup.py.example"
-PYTHON_MODNAME="DistUtilsExtra"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable broken tests.
- sed \
- -e "s/test_desktop/_&/" \
- -e "s/test_po(/_&/" \
- -e "s/test_policykit/_&/" \
- -e "s/test_requires_provides/_&/" \
- -i test/auto.py
-}
-
-src_test() {
- # 5 tests fail with disabled byte-compilation.
- python_enable_pyc
-
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/auto.py
- }
- python_execute_function testing
-
- python_disable_pyc
-}
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.34.ebuild
index e80593caa3ed..2e59dc7de1de 100644
--- a/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.32.ebuild,v 1.1 2012/04/11 07:51:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.34.ebuild,v 1.1 2012/08/29 06:17:05 patrick Exp $
EAPI="3"
PYTHON_DEPEND="2"
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index e06254cf4349..7e079a16473e 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ldap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.110 2012/05/17 19:15:19 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.111 2012/08/29 06:21:34 patrick Exp $
+
+*python-ldap-2.4.10 (29 Aug 2012)
+
+ 29 Aug 2012; Patrick Lauer <patrick@gentoo.org> +python-ldap-2.4.10.ebuild:
+ Bump
17 May 2012; Kacper Kowalik <xarthisius@gentoo.org> python-ldap-2.3.9.ebuild:
Mirror docs for 2.3.9 (built by me)
diff --git a/dev-python/python-ldap/python-ldap-2.4.10.ebuild b/dev-python/python-ldap/python-ldap-2.4.10.ebuild
new file mode 100644
index 000000000000..023a156d6ca4
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.4.10.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.4.10.ebuild,v 1.1 2012/08/29 06:21:34 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils multilib
+
+DESCRIPTION="Various LDAP-related Python modules"
+HOMEPAGE="http://python-ldap.sourceforge.net/ http://pypi.python.org/pypi/python-ldap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="doc examples sasl ssl"
+
+# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
+# python team: Please do not remove python-ldap-2.3.9 from the tree.
+RDEPEND=">=net-nds/openldap-2.4
+ dev-python/pyasn1
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+DOCS="CHANGES README"
+PYTHON_MODNAME="dsml.py ldapurl.py ldif.py ldap"
+
+src_prepare() {
+ local rpath=
+ # sloppy logic, maybe better check if compiler links with GNU-ld
+ [[ ${CHOST} != *-darwin* ]] && rpath="-Wl,-rpath=${EPREFIX}/usr/$(get_libdir)/sasl2"
+ # Note: we can't add /usr/lib and /usr/lib/sasl2 to library_dirs due to a bug in py2.4
+ sed -e "s:^library_dirs =.*:library_dirs =:" \
+ -e "s:^include_dirs =.*:include_dirs = ${EPREFIX}/usr/include ${EPREFIX}/usr/include/sasl:" \
+ -e "s:\(extra_compile_args =\).*:\1\nextra_link_args = ${rpath}:" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs="ldap"
+ if use sasl; then
+ use ssl && mylibs="ldap_r"
+ mylibs="${mylibs} sasl2"
+ else
+ sed -e 's/HAVE_SASL//g' -i setup.cfg || die
+ fi
+ use ssl && mylibs="${mylibs} ssl crypto"
+
+ sed -e "s:^libs = .*:libs = lber resolv ${mylibs}:" \
+ -e "s:^compile.*:compile = 0:" \
+ -e "s:^optimize.*:optimize = 0:" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ pushd Doc &> /dev/null
+ PYTHONPATH="$(ls -d ../build-$(PYTHON -f --ABI)/lib*)" \
+ sphinx-build -b html -d _build/doctrees . _build/html
+ popd Doc &> /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r Demo
+ fi
+
+ if use doc; then
+ dohtml -r Doc/_build/html/
+ fi
+}