summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-02-16 20:24:30 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-02-16 20:24:30 +0000
commit7518976ee11eabfe18b388b745dc54f1b89059a0 (patch)
tree1b2c0b5353f16efb8b144e6a7dfe00d0cf169135 /dev-python
parentbug #15613 (diff)
downloadhistorical-7518976ee11eabfe18b388b745dc54f1b89059a0.tar.gz
historical-7518976ee11eabfe18b388b745dc54f1b89059a0.tar.bz2
historical-7518976ee11eabfe18b388b745dc54f1b89059a0.zip
version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.31
-rw-r--r--dev-python/twisted/twisted-1.0.3.ebuild33
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 71d47ecb8e6b..dd6cfbc2f2f4 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.13 2003/02/12 06:35:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.14 2003/02/16 20:24:30 lordvan Exp $
+*twisted-1.0.3 (16 Feb 2003)
+ 16 Feb 2003; Thomas Raschbacher <lordvan@gentoo.org>: twisted-1.0.3.ebuild
+ version bump (~arch)
+
*twisted-1.0.2 (29 Jan 2003)
29 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org>: twisted-1.0.2.ebuild
version bump (~arch cuz of freeze)
diff --git a/dev-python/twisted/files/digest-twisted-1.0.3 b/dev-python/twisted/files/digest-twisted-1.0.3
new file mode 100644
index 000000000000..497271b01ba3
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.3
@@ -0,0 +1 @@
+MD5 01f24f2329d6320ba26f38aa880feba3 Twisted-1.0.3.tar.bz2 3637666
diff --git a/dev-python/twisted/twisted-1.0.3.ebuild b/dev-python/twisted/twisted-1.0.3.ebuild
new file mode 100644
index 000000000000..3479c70fea45
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.3.ebuild,v 1.1 2003/02/16 20:24:30 lordvan Exp $
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python
+ >=dev-python/pycrypto-1.9_alpha4"
+RDEPEND="$DEPEND"
+KEYWORDS="~x86 ~alpha ~sparc "
+IUSE=""
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
+# should be taken care of by the distutils install
+# dodoc README TODO CREDITS
+}
+