summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-12 06:32:09 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-12 06:32:09 +0000
commit9ac2e2b9d7c52384471db090dd2289907c8ee833 (patch)
treed925fd886a41705eafe32684a4c037fa4402c5e5 /dev-python
parentRemoved RDEPEND=${DEPEND} (diff)
downloadhistorical-9ac2e2b9d7c52384471db090dd2289907c8ee833.tar.gz
historical-9ac2e2b9d7c52384471db090dd2289907c8ee833.tar.bz2
historical-9ac2e2b9d7c52384471db090dd2289907c8ee833.zip
Removed RDEPEND=${DEPEND}
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ReportLab/ReportLab-1.11.ebuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/dev-python/ReportLab/ReportLab-1.11.ebuild b/dev-python/ReportLab/ReportLab-1.11.ebuild
index 3323e324bb7a..df961f1cd247 100644
--- a/dev-python/ReportLab/ReportLab-1.11.ebuild
+++ b/dev-python/ReportLab/ReportLab-1.11.ebuild
@@ -1,33 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ReportLab-1.11.ebuild,v 1.6 2002/10/17 16:36:53 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ReportLab-1.11.ebuild,v 1.7 2002/11/12 06:32:09 vapier Exp $
#goofy tarball versioning
vmaj=${PV%%.*}
vmin=${PV##*.}
-S=${WORKDIR}/reportlab
DESCRIPTION="Tools for generating printable PDF documents from any data source."
SRC_URI="http://www.reportlab.com/ftp/${PN}_${vmaj}_${vmin}.tgz"
HOMEPAGE="http://www.reportlab.com/"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc sparc64 alpha"
+
DEPEND=">=dev-lang/python-2.0
>=sys-libs/zlib-0.95
dev-python/Imaging"
-RDEPEND=${DEPEND}
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="x86 sparc sparc64 alpha"
+S=${WORKDIR}/reportlab
src_install() {
-
#grab python verision so ebuild doesn't depend on it
local pv
pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
-
insinto /usr/lib/python$pv/site-packages
echo "reportlab" > reportlab.pth
doins reportlab.pth
@@ -36,10 +33,5 @@ src_install() {
cp -a reportlab ${D}/usr/lib/python$pv/site-packages
cd ${S}
- dodoc README license.txt
-
+ dodoc README license.txt
}
-
-
-
-