summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2004-05-31 18:11:31 +0000
committerSteve Arnold <nerdboy@gentoo.org>2004-05-31 18:11:31 +0000
commitc8bb34d1d7d822af214c42b4817f7b7dd45dfd87 (patch)
tree7806313e1d6ec440665c4ddf14e6849263d8b35b /dev-python
parentdont install stupid COPYING file (diff)
downloadhistorical-c8bb34d1d7d822af214c42b4817f7b7dd45dfd87.tar.gz
historical-c8bb34d1d7d822af214c42b4817f7b7dd45dfd87.tar.bz2
historical-c8bb34d1d7d822af214c42b4817f7b7dd45dfd87.zip
new ebuild for PyClimate 1.2.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyClimate/ChangeLog10
-rw-r--r--dev-python/PyClimate/Manifest4
-rw-r--r--dev-python/PyClimate/PyClimate-1.2.1.ebuild32
-rw-r--r--dev-python/PyClimate/files/digest-PyClimate-1.2.11
-rw-r--r--dev-python/PyClimate/metadata.xml18
5 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/PyClimate/ChangeLog b/dev-python/PyClimate/ChangeLog
new file mode 100644
index 000000000000..e9b6e7955d1c
--- /dev/null
+++ b/dev-python/PyClimate/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/PyClimate
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyClimate/ChangeLog,v 1.1 2004/05/31 18:11:31 nerdboy Exp $
+
+*PyClimate-1.2.1 (31 May 2004)
+
+ 31 May 2004; Steve Arnold <nerdboy@gentoo.org> PyClimate-1.2.1.ebuild,
+ metadata.xml:
+ new ebuild for climate analysis stuff in python
+
diff --git a/dev-python/PyClimate/Manifest b/dev-python/PyClimate/Manifest
new file mode 100644
index 000000000000..61c8690f451d
--- /dev/null
+++ b/dev-python/PyClimate/Manifest
@@ -0,0 +1,4 @@
+MD5 d704534b86e2653d25b4e2f4c6b9e1e1 PyClimate-1.2.1.ebuild 921
+MD5 5711f48155e6a9f7f569dab40265e627 metadata.xml 729
+MD5 a39bdb2cec7fb3be0f0f6956379e68db ChangeLog 395
+MD5 f8ee275409815fba5c7c815d370748bf files/digest-PyClimate-1.2.1 67
diff --git a/dev-python/PyClimate/PyClimate-1.2.1.ebuild b/dev-python/PyClimate/PyClimate-1.2.1.ebuild
new file mode 100644
index 000000000000..db829133e637
--- /dev/null
+++ b/dev-python/PyClimate/PyClimate-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyClimate/PyClimate-1.2.1.ebuild,v 1.1 2004/05/31 18:11:31 nerdboy Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Climate Data Analysis Module for Python"
+SRC_URI="http://starship.python.net/crew/jsaenz/pyclimate/downloads/${P}.tar.gz"
+HOMEPAGE="http://starship.python.net/crew/jsaenz/pyclimate/index.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-19.0
+ dev-python/ScientificPython
+ >=app-sci/netcdf-3.0"
+
+src_install() {
+ python setup.py install --prefix=${D}/usr || die "Python Install Failed"
+
+ dodoc README PKG-INFO
+
+ dodir /usr/share/doc/${PF}/doc
+ insinto /usr/share/doc/${PF}/doc
+ doins doc/*
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}
diff --git a/dev-python/PyClimate/files/digest-PyClimate-1.2.1 b/dev-python/PyClimate/files/digest-PyClimate-1.2.1
new file mode 100644
index 000000000000..b4eada622105
--- /dev/null
+++ b/dev-python/PyClimate/files/digest-PyClimate-1.2.1
@@ -0,0 +1 @@
+MD5 2d19f9622cdc5f3107b90157fcd9266c PyClimate-1.2.1.tar.gz 336090
diff --git a/dev-python/PyClimate/metadata.xml b/dev-python/PyClimate/metadata.xml
new file mode 100644
index 000000000000..823827079d0b
--- /dev/null
+++ b/dev-python/PyClimate/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+ <description>Primary Maintainer</description>
+</maintainer>
+<longdescription>
+ A package designed to accomplish some usual tasks during the analysis of
+ climate variability using Python. It provides functions to perform some
+ simple IO operations, operations with COARDS-compliant netCDF files, EOF
+ analysis, SVD and CCA analysis of coupled data sets, some linear digital
+ filters, kernel based probability density function estimation and access
+ to DCDFLIB.C library.
+</longdescription>
+</pkgmetadata>