summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-09 17:09:58 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-09 17:09:58 +0000
commitdea79aede108cda78e68194a75023ad62fcf061f (patch)
tree0e460f9489a14fd4225802af2c23e206649160de /dev-ruby/actionpack
parentReally remove old (diff)
downloadhistorical-dea79aede108cda78e68194a75023ad62fcf061f.tar.gz
historical-dea79aede108cda78e68194a75023ad62fcf061f.tar.bz2
historical-dea79aede108cda78e68194a75023ad62fcf061f.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.3.12.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 0684a93ca767..e9e108baecd1 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.176 2011/06/09 15:22:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.177 2011/06/09 17:08:16 graaff Exp $
+
+*actionpack-2.3.12 (09 Jun 2011)
+
+ 09 Jun 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-2.3.12.ebuild:
+ Version bump.
09 Jun 2011; Hans de Graaff <graaff@gentoo.org> -actionpack-2.2.3-r1.ebuild,
-files/actionpack-2.2.3-strip_tags.patch:
diff --git a/dev-ruby/actionpack/actionpack-2.3.12.ebuild b/dev-ruby/actionpack/actionpack-2.3.12.ebuild
new file mode 100644
index 000000000000..ae7711354354
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.12.ebuild,v 1.1 2011/06/09 17:08:16 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.3.11-rails3.patch" "${PN}-2.3.10-i18n-0.4.2.patch" )
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-1.1.0:0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.7
+ dev-ruby/activerecord:${SLOT}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ # This tries to load a “vendorized” copy of activerecord that we
+ # will never have. It can now also use a normally installed
+ # version but these tests fail.
+ sed -i -e '/PATH_TO_AR/s:^:#:' -e 's/self.able_to_connect = true/self.able_to_connect = false/' test/active_record_unit.rb || die
+
+ # Fix the testsuite, the symlink is not present in the gem for
+ # some reason
+ ln -s ../../symlink_parent test/fixtures/layout_tests/layouts/symlinked
+
+ # MemCacheStore tests no longer fail gracefully, and it's unlikely for
+ # someone to have them running anyway, so remove them for now.
+ rm test/controller/session/mem_cache_store_test.rb || die
+
+ # Fix tests when run against i18n 0.4.2 which ignores locale
+ # definitions with an empty data section.
+ sed -i -e 's/, {}/, {:test => "test"}/' test/template/render_test.rb || die
+}