summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-28 08:20:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-28 08:20:24 +0000
commit1b5862659a584d73d3c7e37faea07b9f593b8df7 (patch)
tree325c69923b0d579b0959d79320de733f62832ed0 /dev-ruby/activeresource
parentVersion bump for Rails 3.0.16, bug 428254. (diff)
downloadhistorical-1b5862659a584d73d3c7e37faea07b9f593b8df7.tar.gz
historical-1b5862659a584d73d3c7e37faea07b9f593b8df7.tar.bz2
historical-1b5862659a584d73d3c7e37faea07b9f593b8df7.zip
Version bump for Rails 3.0.16, bug 428254.
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.16.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index b517705f22ec..f68b3843e0cc 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.116 2012/07/28 07:38:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.117 2012/07/28 08:17:17 graaff Exp $
+
+*activeresource-3.0.16 (28 Jul 2012)
+
+ 28 Jul 2012; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.16.ebuild:
+ Version bump for Rails 3.0.16, bug 428254.
*activeresource-3.1.7 (28 Jul 2012)
diff --git a/dev-ruby/activeresource/activeresource-3.0.16.ebuild b/dev-ruby/activeresource/activeresource-3.0.16.ebuild
new file mode 100644
index 000000000000..d1f82d0e13d2
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.16.ebuild,v 1.1 2012/07/28 08:17:17 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}