summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-06 14:47:18 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-06 14:47:18 +0000
commit5ca65c3824ad7d89221296464f299254e7b22613 (patch)
tree0e8922e7488b7bfa02fa27ac3bca01de130d6cfe /dev-ruby/bundler
parentRespect CC,CFLAGS #365863. Use dohtml -r #365861. Install CREDITS file. EAPI=... (diff)
downloadhistorical-5ca65c3824ad7d89221296464f299254e7b22613.tar.gz
historical-5ca65c3824ad7d89221296464f299254e7b22613.tar.bz2
historical-5ca65c3824ad7d89221296464f299254e7b22613.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/bundler')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.0.13.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index e2619210653a..e648ff336d4d 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.15 2011/04/09 05:44:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.16 2011/05/06 14:41:54 graaff Exp $
+
+*bundler-1.0.13 (06 May 2011)
+
+ 06 May 2011; Hans de Graaff <graaff@gentoo.org> +bundler-1.0.13.ebuild:
+ Version bump.
*bundler-1.0.12 (09 Apr 2011)
diff --git a/dev-ruby/bundler/bundler-1.0.13.ebuild b/dev-ruby/bundler/bundler-1.0.13.ebuild
new file mode 100644
index 000000000000..ae7d1735a074
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.0.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.13.ebuild,v 1.1 2011/05/06 14:41:55 graaff Exp $
+
+EAPI=2
+
+# ruby19 → uncountable number of test failures
+# jruby → needs to be tested because jruby-1.5.1 fails in multiple
+# ways unrelated to this package
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/rubygems
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+RDEPEND="${RDEPEND}
+ dev-vcs/git"
+DEPEND="${DEPEND}
+ test? ( dev-vcs/git )"
+
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-1.0.3-gentoo.patch )
+
+all_ruby_prepare() {
+ # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '685s/should/should_not/' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '49,54d' spec/install/deploy_spec.rb || die
+}