summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-03 16:16:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-03 16:16:01 +0000
commit83898b0e77a32ac4c1fe9ac9902190d47450de23 (patch)
tree0ce78f4a5a1691f1014bd66a1eee39a92efaf2d0 /dev-ruby/execjs/execjs-2.0.2.ebuild
parentFix config file move - bug #486624 (diff)
downloadhistorical-83898b0e77a32ac4c1fe9ac9902190d47450de23.tar.gz
historical-83898b0e77a32ac4c1fe9ac9902190d47450de23.tar.bz2
historical-83898b0e77a32ac4c1fe9ac9902190d47450de23.zip
Version bump.
Package-Manager: portage-2.2.7/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/execjs/execjs-2.0.2.ebuild')
-rw-r--r--dev-ruby/execjs/execjs-2.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/execjs/execjs-2.0.2.ebuild b/dev-ruby/execjs/execjs-2.0.2.ebuild
new file mode 100644
index 000000000000..001d6f81c6f0
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/execjs-2.0.2.ebuild,v 1.1 2013/10/03 16:15:57 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/sstephenson/execjs"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, node.js, spidermonkey (deprecated)
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND+=" || ( net-libs/nodejs )"