summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-09 17:28:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-09 17:28:24 +0000
commite5a5ecf2ed050707540663beab0bb79e3c98aba6 (patch)
tree359bd868114899d0e691bfe8beba7c391245876c /dev-ruby/oauth2/oauth2-0.8.0.ebuild
parentVersion bump to catalyst-2.0.11. (diff)
downloadhistorical-e5a5ecf2ed050707540663beab0bb79e3c98aba6.tar.gz
historical-e5a5ecf2ed050707540663beab0bb79e3c98aba6.tar.bz2
historical-e5a5ecf2ed050707540663beab0bb79e3c98aba6.zip
Version bump. Drop x86 due to new dependencies, bug 434488.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/oauth2/oauth2-0.8.0.ebuild')
-rw-r--r--dev-ruby/oauth2/oauth2-0.8.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/oauth2-0.8.0.ebuild b/dev-ruby/oauth2/oauth2-0.8.0.ebuild
new file mode 100644
index 000000000000..fc036b6770ab
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.8.0.ebuild,v 1.1 2012/09/09 17:28:24 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/httpauth-0.1
+ >=dev-ruby/jwt-0.1.4
+ >=dev-ruby/multi_json-1.0.3
+ >=dev-ruby/rack-1.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
+
+all_ruby_prepare() {
+ rm .rspec || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}