summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-21 18:40:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-21 18:40:31 +0000
commit2b24183623762e6de5dd50e107b0175c511c6ce5 (patch)
tree4554dd13a42bdc74dd80d2cc8baacc33f6e7b5fb /dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild
parentFix old-style Qt4 depend (diff)
downloadhistorical-2b24183623762e6de5dd50e107b0175c511c6ce5.tar.gz
historical-2b24183623762e6de5dd50e107b0175c511c6ce5.tar.bz2
historical-2b24183623762e6de5dd50e107b0175c511c6ce5.zip
Initial import of rake-compiler, to be used by nokogiri and sqlite3-ruby.
Package-Manager: portage-2.2_rc60/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild')
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild
new file mode 100644
index 000000000000..3052e1e6d08d
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.0.ebuild,v 1.1 2009/12/21 18:40:31 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="cucumber"
+
+RUBY_FAKEGEM_DOCDIR="doc/api"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="as-is" # truly
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+S="${WORKDIR}/luislavena-${PN}-2834041"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""