summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-23 09:39:11 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-23 09:39:11 +0000
commit1f12634216cf582e6db873ba93d8cd0454fa98c8 (patch)
tree9b3ff9c9318f8d5c3f20e8c43a8588b394164e42 /dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild
parentAdded Prefix keywords (diff)
downloadhistorical-1f12634216cf582e6db873ba93d8cd0454fa98c8.tar.gz
historical-1f12634216cf582e6db873ba93d8cd0454fa98c8.tar.bz2
historical-1f12634216cf582e6db873ba93d8cd0454fa98c8.zip
Revision bump to create stable candidate with ree18.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild')
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild b/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild
new file mode 100644
index 000000000000..24389f12dd07
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild,v 1.1 2011/01/23 09:39:11 graaff Exp $
+
+EAPI=2
+
+# jruby → tests still fail with UTF-8 characters
+# http://jgarber.lighthouseapp.com/projects/13054/tickets/149-redcloth-4-doesnt-support-multi-bytes-content
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RedCloth"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://redcloth.org/"
+
+SRC_URI="http://github.com/jgarber/redcloth/tarball/RELEASE_$(replace_all_version_separators _) -> ${RUBY_FAKEGEM_NAME}-git-${PV}.tgz
+ http://dev.gentoo.org/~flameeyes/patches/${PN}/${P}+ruby-1.9.2.patch.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="$DEPEND
+ dev-util/ragel"
+RDEPEND="$RDEPEND"
+
+S="${WORKDIR}/jgarber-${PN}-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake
+ >=dev-ruby/echoe-3.0.1
+ test? (
+ dev-ruby/rspec
+ dev-ruby/diff-lcs
+ )"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${DISTDIR}"/${P}+ruby-1.9.2.patch.bz2
+)
+
+pkg_setup() {
+ # Export the VERBOSE variable to avoid remapping of stdout and
+ # stderr, and that breaks because of bad interactions between
+ # echoe, Ruby and Gentoo.
+ export VERBOSE=1
+}
+
+each_ruby_compile() {
+ # We cannot run this manually easily, because Ragel re-generation
+ # is a mess
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+each_ruby_test() {
+ find spec -name '*_spec.rb' -print0 | xargs -0 ${RUBY} -I lib -S spec -Du -fs
+}