summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-02 06:05:37 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-02 06:05:37 +0000
commitbc7a0d9fd2d30433fc688e0d1cd45a59d436b9f7 (patch)
tree3e749faf082cc7f8b693b8b60b89025f9a0bd86d /dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
parentWhitespace. (diff)
downloadhistorical-bc7a0d9fd2d30433fc688e0d1cd45a59d436b9f7.tar.gz
historical-bc7a0d9fd2d30433fc688e0d1cd45a59d436b9f7.tar.bz2
historical-bc7a0d9fd2d30433fc688e0d1cd45a59d436b9f7.zip
Version bump.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
new file mode 100644
index 000000000000..60701f45e6d9
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild,v 1.1 2014/08/02 06:05:36 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ >=dev-ruby/rspec-mocks-2.14.0:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid a weird, and failing, test testing already installed code.
+ sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/expectations_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid a test failing on backtrace details.
+ sed -e '/when the root file is loaded/,/end/ s:^:#:' -i spec/rspec/expectations_spec.rb || die
+ ;;
+ esac
+}