summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-02 13:07:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-02 13:07:15 +0000
commit299815c5960457f3c4ec150f969f63ec4d019bde (patch)
tree868a41204b41f24efb7ab4ecb118f2d82268b14b /dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild
parentStable on ppc64; bug #134194 (diff)
downloadhistorical-299815c5960457f3c4ec150f969f63ec4d019bde.tar.gz
historical-299815c5960457f3c4ec150f969f63ec4d019bde.tar.bz2
historical-299815c5960457f3c4ec150f969f63ec4d019bde.zip
Add patch to build with rrdtool 1.2, thanks to Angelo Leto in bug #132570. Mark ~amd64.
Package-Manager: portage-2.1_rc3-r5
Diffstat (limited to 'dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild')
-rw-r--r--dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild b/dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild
index 8a9516d47600..340390947b66 100644
--- a/dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild
+++ b/dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild,v 1.2 2005/01/04 15:32:47 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-rrd/ruby-rrd-1.1.ebuild,v 1.3 2006/06/02 13:07:15 flameeyes Exp $
inherit ruby
@@ -11,19 +11,26 @@ DESCRIPTION="Simple RRDTool wrapper for Ruby"
HOMEPAGE="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/"
SRC_URI="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/contrib/${P}.tar.gz"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
LICENSE="Ruby"
SLOT="0"
DEPEND="virtual/ruby
>=net-analyzer/rrdtool-1.0.47"
+src_unpack() {
+ ruby_src_unpack
+
+ has_version '>=net-analyzer/rrdtool-1.2' && \
+ epatch "${FILESDIR}/${PN}-rrdtool-1.2.patch"
+}
+
src_compile() {
ruby extconf.rb || die
emake || die
}
src_install() {
- einstall || die
+ make DESTDIR="${D}" install || die
dodoc README test.rb
}