summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-27 05:44:42 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-27 05:44:42 +0000
commit7152678ec3f8850bdf9c1b14ec059b843df46fae (patch)
tree3f842c48feb093a4c941f2f9880c618a74c68f94 /dev-ruby/webrat/webrat-0.7.1.ebuild
parentremove unused use flag (diff)
downloadhistorical-7152678ec3f8850bdf9c1b14ec059b843df46fae.tar.gz
historical-7152678ec3f8850bdf9c1b14ec059b843df46fae.tar.bz2
historical-7152678ec3f8850bdf9c1b14ec059b843df46fae.zip
Version bump: various enhancements and bug fixes.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/webrat/webrat-0.7.1.ebuild')
-rw-r--r--dev-ruby/webrat/webrat-0.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/webrat/webrat-0.7.1.ebuild b/dev-ruby/webrat/webrat-0.7.1.ebuild
new file mode 100644
index 000000000000..8564322528e9
--- /dev/null
+++ b/dev-ruby/webrat/webrat-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/webrat/webrat-0.7.1.ebuild,v 1.1 2010/04/27 05:44:42 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="spec:integration:rack spec:integration:sinatra spec:integration:mechanize"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby acceptance testing for web applications"
+HOMEPAGE="http://github.com/brynary/webrat/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.2.0
+ >=dev-ruby/rack-1.0"
+
+ruby_add_bdepend test "dev-ruby/rspec dev-ruby/rack-test dev-ruby/sinatra dev-ruby/mechanize"