summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-03 16:25:18 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-03 16:25:18 +0000
commit03d90e43986da7948d8da6721cb1c721b197f871 (patch)
tree322b0c79c9c5054b8379c3dae9bfeb68e394851f /dev-ruby
parentactivemodel does not contain database-specific parts: remove USE flags. (diff)
downloadhistorical-03d90e43986da7948d8da6721cb1c721b197f871.tar.gz
historical-03d90e43986da7948d8da6721cb1c721b197f871.tar.bz2
historical-03d90e43986da7948d8da6721cb1c721b197f871.zip
Version bump for Rails 3.0.3.
Package-Manager: portage-2.1.9.24/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.3.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 9af79cb17090..a9ecc82b8dbe 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.70 2010/10/15 08:00:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.71 2010/12/03 16:25:18 graaff Exp $
+
+*activeresource-3.0.3 (03 Dec 2010)
+
+ 03 Dec 2010; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.3.ebuild:
+ Version bump for Rails 3.0.3.
15 Oct 2010; Hans de Graaff <graaff@gentoo.org>
-activeresource-2.3.9.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-3.0.3.ebuild b/dev-ruby/activeresource/activeresource-3.0.3.ebuild
new file mode 100644
index 000000000000..09c0d71932c9
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.3.ebuild,v 1.1 2010/12/03 16:25:18 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}