summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 01:47:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 01:47:46 +0000
commit82afaeb4c71260b06009e66c6e9bfa1b0d211f7a (patch)
treefad21ca2f4d645cc0b3eaf61b66c05e7c96b85ac /dev-ruby
parentRemove old version that still requires an old hashie. (diff)
downloadhistorical-82afaeb4c71260b06009e66c6e9bfa1b0d211f7a.tar.gz
historical-82afaeb4c71260b06009e66c6e9bfa1b0d211f7a.tar.bz2
historical-82afaeb4c71260b06009e66c6e9bfa1b0d211f7a.zip
Cleanup old versions and update to new syntax.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/httparty/ChangeLog7
-rw-r--r--dev-ruby/httparty/httparty-0.4.5.ebuild18
-rw-r--r--dev-ruby/httparty/httparty-0.5.2.ebuild60
-rw-r--r--dev-ruby/httparty/httparty-0.6.0.ebuild60
-rw-r--r--dev-ruby/httparty/httparty-0.6.1.ebuild4
5 files changed, 8 insertions, 141 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index 7aa8ed278237..6af45d07f9ac 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httparty
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.17 2010/07/19 07:29:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.18 2010/07/29 01:47:46 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -httparty-0.4.5.ebuild, -httparty-0.5.2.ebuild, -httparty-0.6.0.ebuild,
+ httparty-0.6.1.ebuild:
+ Cleanup old versions and update to new syntax.
*httparty-0.6.1 (19 Jul 2010)
diff --git a/dev-ruby/httparty/httparty-0.4.5.ebuild b/dev-ruby/httparty/httparty-0.4.5.ebuild
deleted file mode 100644
index a2d481ad069b..000000000000
--- a/dev-ruby/httparty/httparty-0.4.5.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.4.5.ebuild,v 1.1 2009/10/03 12:48:38 a3li Exp $
-
-inherit gems
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
-HOMEPAGE="http://httparty.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-USE_RUBY="ruby18"
-
-DEPEND=">=dev-ruby/crack-0.1.1"
-RDEPEND="${DEPEND}"
diff --git a/dev-ruby/httparty/httparty-0.5.2.ebuild b/dev-ruby/httparty/httparty-0.5.2.ebuild
deleted file mode 100644
index fef61ae09d34..000000000000
--- a/dev-ruby/httparty/httparty-0.5.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.5.2.ebuild,v 1.3 2010/05/28 17:46:48 josejx Exp $
-
-EAPI=2
-
-# ruby19 → testsuite fails (might be crack's bug)
-# jruby → testsuite fails (seems like a testuite bug)
-USE_RUBY="ruby18"
-
-# We have a custom test function, but don't null this out so that the
-# deps are still added
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
-HOMEPAGE="http://httparty.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-# Code should most likely be patched, but for now…
-ruby_add_rdepend '~dev-ruby/crack-0.1.6'
-
-ruby_add_bdepend 'dev-ruby/rspec dev-ruby/fakeweb'
-
-USE_RUBY=ruby18 \
- ruby_add_bdepend 'ruby_targets_ruby18 test' 'dev-util/cucumber dev-ruby/activesupport:2.3'
-
-all_ruby_prepare() {
- # as often, Rakefile depends on Jeweler's presence
- sed -i \
- -e '/check_dependencies/s:^:#:' \
- Rakefile || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby18)
- # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
- ${RUBY} -S rake spec features || die "cucumber tests failed"
- ;;
- *)
- ${RUBY} -S rake spec || die "cucumber tests failed"
- ;;
- esac
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/httparty/httparty-0.6.0.ebuild b/dev-ruby/httparty/httparty-0.6.0.ebuild
deleted file mode 100644
index d55d244f83f5..000000000000
--- a/dev-ruby/httparty/httparty-0.6.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.6.0.ebuild,v 1.1 2010/06/25 20:23:05 graaff Exp $
-
-EAPI=2
-
-# ruby19 → testsuite fails (might be crack's bug)
-# jruby → testsuite fails (seems like a testuite bug)
-USE_RUBY="ruby18"
-
-# We have a custom test function, but don't null this out so that the
-# deps are still added
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
-HOMEPAGE="http://httparty.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-# Code should most likely be patched, but for now…
-ruby_add_rdepend '~dev-ruby/crack-0.1.7'
-
-ruby_add_bdepend 'dev-ruby/rspec dev-ruby/fakeweb'
-
-USE_RUBY=ruby18 \
- ruby_add_bdepend 'ruby_targets_ruby18 test' 'dev-util/cucumber dev-ruby/activesupport:2.3'
-
-all_ruby_prepare() {
- # as often, Rakefile depends on Jeweler's presence
- sed -i \
- -e '/check_dependencies/s:^:#:' \
- Rakefile || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby18)
- # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
- ${RUBY} -S rake spec features || die "cucumber tests failed"
- ;;
- *)
- ${RUBY} -S rake spec || die "cucumber tests failed"
- ;;
- esac
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/httparty/httparty-0.6.1.ebuild b/dev-ruby/httparty/httparty-0.6.1.ebuild
index 53df9a1d0215..e3e0810eacd9 100644
--- a/dev-ruby/httparty/httparty-0.6.1.ebuild
+++ b/dev-ruby/httparty/httparty-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.6.1.ebuild,v 1.1 2010/07/19 07:29:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.6.1.ebuild,v 1.2 2010/07/29 01:47:46 flameeyes Exp $
EAPI=2
@@ -31,7 +31,7 @@ ruby_add_rdepend '~dev-ruby/crack-0.1.8'
ruby_add_bdepend 'dev-ruby/rspec dev-ruby/fakeweb'
USE_RUBY=ruby18 \
- ruby_add_bdepend 'ruby_targets_ruby18 test' 'dev-util/cucumber dev-ruby/activesupport:2.3'
+ ruby_add_bdepend 'test? ( dev-util/cucumber dev-ruby/activesupport:2.3 )'
all_ruby_prepare() {
# as often, Rakefile depends on Jeweler's presence