summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-13 06:48:45 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-13 06:48:45 +0000
commitc69e069ecc6237745d4cefb0c519f6f26f2d1bfb (patch)
tree927c386b5dd8d8e10868b875e0a1a8652407f412 /dev-ruby
parentVersion bump. (diff)
downloadhistorical-c69e069ecc6237745d4cefb0c519f6f26f2d1bfb.tar.gz
historical-c69e069ecc6237745d4cefb0c519f6f26f2d1bfb.tar.bz2
historical-c69e069ecc6237745d4cefb0c519f6f26f2d1bfb.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild45
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog7
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild53
-rw-r--r--dev-ruby/rspec-rails/ChangeLog7
-rw-r--r--dev-ruby/rspec-rails/rspec-rails-2.6.0.ebuild36
-rw-r--r--dev-ruby/rspec/ChangeLog7
-rw-r--r--dev-ruby/rspec/rspec-2.6.0.ebuild26
8 files changed, 185 insertions, 4 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 31bd9607a1fd..d8d6d5d0d9b0 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.6 2011/02/19 09:26:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.7 2011/05/13 06:42:19 graaff Exp $
+
+*rspec-expectations-2.6.0 (13 May 2011)
+
+ 13 May 2011; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.6.0.ebuild:
+ Version bump.
*rspec-expectations-2.5.0 (19 Feb 2011)
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
new file mode 100644
index 000000000000..028cae6ee773
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild,v 1.1 2011/05/13 06:42:19 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.4.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec
+
+ # There are features but they require aruba which we don't have yet.
+}
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index 79210740d76c..4e5a5d67e7fe 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.8 2011/02/19 09:26:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.9 2011/05/13 06:45:16 graaff Exp $
+
+*rspec-mocks-2.6.0 (13 May 2011)
+
+ 13 May 2011; Hans de Graaff <graaff@gentoo.org> +rspec-mocks-2.6.0.ebuild:
+ Version bump.
*rspec-mocks-2.5.0 (19 Feb 2011)
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
new file mode 100644
index 000000000000..23ff9f444077
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild,v 1.1 2011/05/13 06:45:16 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# cucumber and rspec-core are loaded unconditionally in the Rakefile,
+# so we also need to require them for USE=doc.
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.6.0:2
+ dev-ruby/rspec-expectations:2
+ )
+ doc? ( dev-ruby/rspec-core:2 )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ RUBYLIB="${S}/lib" rake rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+
+ # There are features but they require aruba which we don't have yet.
+}
diff --git a/dev-ruby/rspec-rails/ChangeLog b/dev-ruby/rspec-rails/ChangeLog
index d8814a43622b..d8b70f6cfdf4 100644
--- a/dev-ruby/rspec-rails/ChangeLog
+++ b/dev-ruby/rspec-rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/ChangeLog,v 1.39 2011/02/19 11:35:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/ChangeLog,v 1.40 2011/05/13 06:48:45 graaff Exp $
+
+*rspec-rails-2.6.0 (13 May 2011)
+
+ 13 May 2011; Hans de Graaff <graaff@gentoo.org> +rspec-rails-2.6.0.ebuild:
+ Version bump.
*rspec-rails-2.5.0 (19 Feb 2011)
diff --git a/dev-ruby/rspec-rails/rspec-rails-2.6.0.ebuild b/dev-ruby/rspec-rails/rspec-rails-2.6.0.ebuild
new file mode 100644
index 000000000000..a24e520e41ff
--- /dev/null
+++ b/dev-ruby/rspec-rails/rspec-rails-2.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/rspec-rails-2.6.0.ebuild,v 1.1 2011/05/13 06:48:45 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.md README.md Upgrade.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec's official Ruby on Rails plugin"
+HOMEPAGE="http://rspec.info/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/activesupport:3.0
+ dev-ruby/actionpack:3.0
+ dev-ruby/railties:3.0
+ dev-ruby/rspec:2"
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die "Tests failed."
+
+ # There are also features but they require aruba which we don't have
+ # yet.
+}
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index 1455c229dce2..bdae7b30ab9b 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.91 2011/04/16 17:27:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.92 2011/05/13 06:46:24 graaff Exp $
+
+*rspec-2.6.0 (13 May 2011)
+
+ 13 May 2011; Hans de Graaff <graaff@gentoo.org> +rspec-2.6.0.ebuild:
+ Version bump.
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> rspec-1.3.1.ebuild:
ia64 stable wrt #356269
diff --git a/dev-ruby/rspec/rspec-2.6.0.ebuild b/dev-ruby/rspec/rspec-2.6.0.ebuild
new file mode 100644
index 000000000000..3c8e7e767205
--- /dev/null
+++ b/dev-ruby/rspec/rspec-2.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0.ebuild,v 1.1 2011/05/13 06:46:24 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-2.5*
+ ~dev-ruby/rspec-expectations-${PV}
+ ~dev-ruby/rspec-mocks-${PV}"