summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-01-24 17:06:06 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-01-24 17:06:06 +0000
commitd2ebf1cf658a8445aef90c06a6b9238d2011b324 (patch)
treec8b9f314ae8454747132c11022fee71f1d395b4d /dev-scheme/slib/slib-3.1.1-r1.ebuild
parentrevision bump 3.1.4 for moving its install destination around. Make install w... (diff)
downloadhistorical-d2ebf1cf658a8445aef90c06a6b9238d2011b324.tar.gz
historical-d2ebf1cf658a8445aef90c06a6b9238d2011b324.tar.bz2
historical-d2ebf1cf658a8445aef90c06a6b9238d2011b324.zip
backport 3.1.4-r1 to 3.1.1-r1
Package-Manager: portage-2.1.2-r2
Diffstat (limited to 'dev-scheme/slib/slib-3.1.1-r1.ebuild')
-rw-r--r--dev-scheme/slib/slib-3.1.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-scheme/slib/slib-3.1.1-r1.ebuild b/dev-scheme/slib/slib-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..f9553647947a
--- /dev/null
+++ b/dev-scheme/slib/slib-3.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/slib/slib-3.1.1-r1.ebuild,v 1.1 2007/01/24 17:06:06 hkbst Exp $
+
+inherit versionator eutils
+
+#version magic thanks to masterdriverz and UberLord using bash array instead of tr
+trarr="0abcdefghi"
+MY_PV="$(get_version_component_range 1)${trarr:$(get_version_component_range 2):1}$(get_version_component_range 3)"
+
+MY_P=${PN}${MY_PV}
+S=${WORKDIR}/${PN}
+DESCRIPTION="library providing functions for Scheme implementations"
+SRC_URI="http://swiss.csail.mit.edu/ftpdir/scm/OLD/${MY_P}.zip"
+
+HOMEPAGE="http://swiss.csail.mit.edu/~jaffer/SLIB"
+
+SLOT="0"
+LICENSE="public-domain BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+#unzip for unpacking
+#depend on guile for now, until slib actually works with another scheme implementation in portage
+RDEPEND="=dev-scheme/guile-1.6*"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+# slib tests rely on scm being installed. It isn't even in portage :(
+RESTRICT="test"
+
+# maybe also do "make infoz"
+
+src_install() {
+ insinto /usr/share/slib/ #don't install directly into guile dir
+ doins *.scm
+ doins *.init
+ dodoc ANNOUNCE ChangeLog FAQ README
+ doinfo slib.info
+ dosym /usr/share/slib/ /usr/share/guile/slib # link from guile dir
+}
+
+pkg_postinst() {
+ einfo "Installing slib for guile..."
+ ${ROOT}/usr/bin/guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
+}