summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2005-02-01 00:13:19 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2005-02-01 00:13:19 +0000
commit60cc73b5f99bd591a04e6cdbbda940b4418752be (patch)
treec9948e40b2ba9e64294733001645389a518a8eff /dev-tcltk/tix/tix-8.2.0-r2.ebuild
parentunstable version bump (diff)
downloadhistorical-60cc73b5f99bd591a04e6cdbbda940b4418752be.tar.gz
historical-60cc73b5f99bd591a04e6cdbbda940b4418752be.tar.bz2
historical-60cc73b5f99bd591a04e6cdbbda940b4418752be.zip
Fixes #79474.
Package-Manager: portage-2.0.51-r13
Diffstat (limited to 'dev-tcltk/tix/tix-8.2.0-r2.ebuild')
-rw-r--r--dev-tcltk/tix/tix-8.2.0-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-tcltk/tix/tix-8.2.0-r2.ebuild b/dev-tcltk/tix/tix-8.2.0-r2.ebuild
new file mode 100644
index 000000000000..92e97672d596
--- /dev/null
+++ b/dev-tcltk/tix/tix-8.2.0-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.2.0-r2.ebuild,v 1.1 2005/02/01 00:13:19 karltk Exp $
+
+inherit eutils
+
+MY_P=${P/-/}
+S=${WORKDIR}/${MY_P}/unix
+DESCRIPTION="A widget library for Tcl/Tk. Has been ported to Python and Perl, too."
+HOMEPAGE="http://sourceforge.net/projects/tixlibrary/"
+SRC_URI="mirror://sourceforge/tixlibrary/${MY_P}b1.tar.gz"
+IUSE=""
+LICENSE="as-is BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4
+ dev-lang/tk"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/..
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+}
+
+src_compile() {
+ econf \
+ --enable-gcc \
+ --with-tcl=/usr/lib \
+ --with-tk=/usr/lib \
+ --enable-stubs \
+ --enable-threads \
+ --enable-shared || die "./configure failed"
+
+ ebegin "Fixing the Makefile..."
+ sed -e 's:TK_LIBS =:TK_LIBS = -L/usr/X11R6/lib -lX11:' \
+ -e 's:^\(SHLIBS_LD_LIBS.*\):\1 ${TK_LIBS}:' \
+ -i ${S}/Makefile
+
+ eend $?
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/include
+ einstall || die
+}