summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-15 16:17:38 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-15 16:17:38 +0000
commit9258175e73528babeb23397c87a02fe09d42aa7d (patch)
treecc519552071449653dcf7f6328253ca26c81d5d5 /dev-util/as11/as11-1.0.ebuild
parentVersion bump. (diff)
downloadhistorical-9258175e73528babeb23397c87a02fe09d42aa7d.tar.gz
historical-9258175e73528babeb23397c87a02fe09d42aa7d.tar.bz2
historical-9258175e73528babeb23397c87a02fe09d42aa7d.zip
EAPI4, respect CFLAGS, wrt to bug #432722
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-util/as11/as11-1.0.ebuild')
-rw-r--r--dev-util/as11/as11-1.0.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-util/as11/as11-1.0.ebuild b/dev-util/as11/as11-1.0.ebuild
index 15d46b6a2dbe..9bf9ea8d27bf 100644
--- a/dev-util/as11/as11-1.0.ebuild
+++ b/dev-util/as11/as11-1.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/as11/as11-1.0.ebuild,v 1.9 2010/10/02 14:52:28 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/as11/as11-1.0.ebuild,v 1.10 2012/10/15 16:17:38 ago Exp $
-EAPI="2"
+EAPI=4
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Motorola's AS11 Assembler for the 68HC11"
HOMEPAGE="http://www.ai.mit.edu/people/rsargent/as11.html"
@@ -21,14 +21,11 @@ DEPEND=""
RDEPEND=""
src_prepare() {
- sed -i -e "s/ -o/\$(LDFLAGS) -o/g" Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die "Compile failed"
+ epatch "${FILESDIR}"/Makefile.patch
+ tc-export CC
}
src_install() {
- dobin as11
- dodoc as11.doc CHANGELOG README
+ dobin ${PN}
+ dodoc ${PN}.doc CHANGELOG README
}