summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-01-18 15:59:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-01-18 15:59:14 +0000
commit80bb625af0a54c6ad038bdfd5a41558515e6f103 (patch)
tree27dfa08cc9a19fe7219a5c0c18586605af0ea718 /dev-util/bitkeeper
parentstable on alpha (diff)
downloadhistorical-80bb625af0a54c6ad038bdfd5a41558515e6f103.tar.gz
historical-80bb625af0a54c6ad038bdfd5a41558515e6f103.tar.bz2
historical-80bb625af0a54c6ad038bdfd5a41558515e6f103.zip
Version bumped since 3.0 is no more available.
Diffstat (limited to 'dev-util/bitkeeper')
-rw-r--r--dev-util/bitkeeper/ChangeLog7
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/bitkeeper/ChangeLog b/dev-util/bitkeeper/ChangeLog
index fba577a81b57..b65e0b55d0cd 100644
--- a/dev-util/bitkeeper/ChangeLog
+++ b/dev-util/bitkeeper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bitkeeper
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.4 2002/12/23 17:22:28 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.5 2003/01/18 15:59:14 mholzer Exp $
+
+*bitkeeper-3.0.1 (18 Jan 2003)
+
+ 18 Jan 2003; Martin Holzer <mholzer@gentoo.org> bitkeeper-3.0.1.ebuild ChangeLog :
+ Version bumped since 3.0 is no more available.
*bitkeeper-3.0-r1 (18 Nov 2002)
diff --git a/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild b/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
new file mode 100644
index 000000000000..4e7883d12b24
--- /dev/null
+++ b/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild,v 1.1 2003/01/18 15:59:14 mholzer Exp $
+
+DESCRIPTION="BitKeeper is a scalable configuration management system."
+SRC_URI=""
+HOMEPAGE="http://www.bitkeeper.com"
+
+SLOT="0"
+LICENSE="BKL"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=virtual/glibc-2.2
+ >=dev-lang/tcl-8.3.3
+ X? ( >=dev-lang/tk-8.3.3 )"
+
+# I'm not sure what the official way to do this is...
+use 'x86' >/dev/null && A="bk-3.0.1-x86-glibc22-linux.bin"
+use 'ppc' >/dev/null && A="bk-3.0.1-powerpc-glibc21-linux.bin"
+use 'sparc' >/dev/null && A="bk-3.0.1-sparc-glibc21-linux.bin"
+use 'alpha' >/dev/null && A="bk-3.0.1-alpha-glibc21-linux.bin"
+
+pkg_setup() {
+ if [ ! -f ${DISTDIR}/${A} ] ; then
+ eerror "You need to perform the following steps to install this package:"
+ eerror "- Sign up at ${HOMEPAGE}"
+ eerror "- Check your mail and visit the download location"
+ eerror "- Download ${A} and place it in ${DISTDIR}"
+ eerror "- emerge this package again"
+ die "package must be downloaded"
+ fi
+}
+
+src_unpack() {
+ mkdir ${S}
+ cp ${DISTDIR}/${A} ${S}/${A}
+ chmod 755 ${S}/${A}
+ echo 'none' | ${S}/${A} > ${S}/output 2>/dev/null
+ installer=`sed -n -e "s/Installation script: \(.*\)/\1/p" ${S}/output`
+ archive=`sed -n -e "s/Gzipped tar archive: \(.*\)/\1/p" ${S}/output`
+ mv $installer ${S}/installer
+ mv $archive ${S}/archive
+}
+
+src_install() {
+ dodir /opt /etc/env.d
+ cd ${D}/opt && tar -xzpf ${S}/archive
+ mv ${D}/opt/bitkeeper ${D}/opt/${P}
+ chown -R root:root ${D}/opt/${P}
+ chmod -R u+w,go-w ${D}/opt/${P}
+ cat <<EOF >${D}/etc/env.d/10bitkeeper
+# Generated by ${P}.ebuild
+PATH=/opt/${P}
+ROOTPATH=/opt/${P}
+MANPATH=/opt/${P}/man
+EOF
+}