summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-03-15 02:18:08 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-03-15 02:18:08 +0000
commit25a5474b31d1b20665a54c3aa2e2df76fa3ba115 (patch)
treea4d674150b4e30263a00e20ec3451d76de22fcb3 /dev-util/cproto
parentReadonly var fixes. (diff)
downloadhistorical-25a5474b31d1b20665a54c3aa2e2df76fa3ba115.tar.gz
historical-25a5474b31d1b20665a54c3aa2e2df76fa3ba115.tar.bz2
historical-25a5474b31d1b20665a54c3aa2e2df76fa3ba115.zip
fix for (gcc-3 related?) build problem
Diffstat (limited to 'dev-util/cproto')
-rw-r--r--dev-util/cproto/ChangeLog10
-rw-r--r--dev-util/cproto/Manifest7
-rw-r--r--dev-util/cproto/cproto-4.6-r1.ebuild36
-rw-r--r--dev-util/cproto/files/4.6-YYSTYPE.patch11
-rw-r--r--dev-util/cproto/files/digest-cproto-4.6-r11
5 files changed, 61 insertions, 4 deletions
diff --git a/dev-util/cproto/ChangeLog b/dev-util/cproto/ChangeLog
index 859e449e4a4f..56adabe878f7 100644
--- a/dev-util/cproto/ChangeLog
+++ b/dev-util/cproto/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for dev-util/cproto
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/ChangeLog,v 1.3 2004/03/13 01:40:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/ChangeLog,v 1.4 2004/03/15 02:18:08 george Exp $
+
+*cproto-4.6-r1 (14 Mar 2004)
+
+ 14 Mar 2004; George Shapovalov <george@gentoo.org> cproto-4.6-r1.ebuild, files/4.6-YYSTYPE.patch :
+ fix (for gcc-3.3 related?) build problem (#44638)
+ thanks to Joe Khoobyar <joe@ankhcraft.com> for report and patch
12 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> cproto-4.6.ebuild:
Don't assign default to S; header fix
-*cproto-4.6.ebuild (06 äÅË 2002)
+*cproto-4.6 (06 äÅË 2002)
06 Dec 2002; George Shapovalov <george@gentoo.org> ChangeLog, cproto-4.6.ebuild, files/\{cproto-4.6-mkstemp.patch,digest-cproto-4.6\} :
initial release
diff --git a/dev-util/cproto/Manifest b/dev-util/cproto/Manifest
index b2c940a0f6d2..c959ba2396f9 100644
--- a/dev-util/cproto/Manifest
+++ b/dev-util/cproto/Manifest
@@ -1,4 +1,7 @@
-MD5 8507ce977bbc974f93e56721d5c1bd3a ChangeLog 621
MD5 8208cb860ee54c8f902a10c5f81c3a79 cproto-4.6.ebuild 723
-MD5 d765e837084055cec0ef65e3f765a728 files/cproto-4.6-mkstemp.patch 1077
+MD5 ec0a05846a41966f9c5ae4c99bd6117a cproto-4.6-r1.ebuild 770
+MD5 b97cb900d8bfd4dc81dc1849f6008612 ChangeLog 861
MD5 7697a7cacbdf87628dfeae27bb4dd163 files/digest-cproto-4.6 62
+MD5 10bb14145eaff685443420d8f3d512ab files/4.6-YYSTYPE.patch 349
+MD5 d765e837084055cec0ef65e3f765a728 files/cproto-4.6-mkstemp.patch 1077
+MD5 7697a7cacbdf87628dfeae27bb4dd163 files/digest-cproto-4.6-r1 62
diff --git a/dev-util/cproto/cproto-4.6-r1.ebuild b/dev-util/cproto/cproto-4.6-r1.ebuild
new file mode 100644
index 000000000000..2b78a536c1ac
--- /dev/null
+++ b/dev-util/cproto/cproto-4.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/cproto-4.6-r1.ebuild,v 1.1 2004/03/15 02:18:08 george Exp $
+
+IUSE=""
+
+DESCRIPTION="generate C function prototypes from C source code"
+SRC_URI="http://dl.sourceforge.net/sourceforge/cproto/cproto-4.6.tar.gz"
+HOMEPAGE="http://cproto.sourceforge.net/"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="public-domain"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ patch -p1 < ${FILESDIR}/${P}-mkstemp.patch
+ epatch ${FILESDIR}/${PV}-YYSTYPE.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+
+ dodir /usr/bin
+ dobin cproto
+ doman cproto.1
+ dodoc README CHANGES
+}
diff --git a/dev-util/cproto/files/4.6-YYSTYPE.patch b/dev-util/cproto/files/4.6-YYSTYPE.patch
new file mode 100644
index 000000000000..3743fef977b0
--- /dev/null
+++ b/dev-util/cproto/files/4.6-YYSTYPE.patch
@@ -0,0 +1,11 @@
+diff -Naur cproto-4.6-old/cproto.h cproto-4.6/cproto.h
+--- cproto-4.6-old/cproto.h 1998-01-18 19:49:16.000000000 -0500
++++ cproto-4.6/cproto.h 2004-03-14 00:02:32.148070032 -0500
+@@ -117,6 +117,7 @@
+ Declarator *declarator;
+ DeclaratorList decl_list;
+ } YYSTYPE;
++#define YYSTYPE_IS_DECLARED 1
+
+ /* Prototype styles */
+ #if OPT_LINTLIBRARY
diff --git a/dev-util/cproto/files/digest-cproto-4.6-r1 b/dev-util/cproto/files/digest-cproto-4.6-r1
new file mode 100644
index 000000000000..8be78525349e
--- /dev/null
+++ b/dev-util/cproto/files/digest-cproto-4.6-r1
@@ -0,0 +1 @@
+MD5 5968d18e9508b2892471e6ef16e140e3 cproto-4.6.tar.gz 124251