summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-07-26 17:31:29 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-07-26 17:31:29 +0000
commit70c7b9782b173144a8538194a0be0e9ba328f097 (patch)
tree140eec1ca7f5bb7051aae01e292c573d0e78f087 /dev-util/cvsd/cvsd-0.9.19.ebuild
parentNew package; thanks to Enrico Morelli. (diff)
downloadhistorical-70c7b9782b173144a8538194a0be0e9ba328f097.tar.gz
historical-70c7b9782b173144a8538194a0be0e9ba328f097.tar.bz2
historical-70c7b9782b173144a8538194a0be0e9ba328f097.zip
New package; thanks to Enrico Morelli.
Diffstat (limited to 'dev-util/cvsd/cvsd-0.9.19.ebuild')
-rw-r--r--dev-util/cvsd/cvsd-0.9.19.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/cvsd/cvsd-0.9.19.ebuild b/dev-util/cvsd/cvsd-0.9.19.ebuild
new file mode 100644
index 000000000000..b8d7ac0a1cad
--- /dev/null
+++ b/dev-util/cvsd/cvsd-0.9.19.ebuild
@@ -0,0 +1,43 @@
+S=${WORKDIR}/${P}
+DESCRIPTION="CVS pserver daemon"
+SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
+HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/cvsd/"
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use tcpd && myconf="${myconf} --with-libwrap"
+
+ econf --prefix=/usr ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ exeinto /usr/sbin
+ doexe cvsd cvsd-buildroot cvsd-passwd
+ insinto /etc/cvsd
+ mv cvsd.conf-dist cvsd.conf
+ doins cvsd.conf
+
+ dodoc COPYING* ChangeLog* FAQ
+ dodoc NEWS README* TODO
+
+ doman cvsd-buildroot.8 cvsd-passwd.8 cvsd.8 cvsd.conf.5
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/cvsd.init cvsd
+ insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
+
+}
+pkg_postinst() {
+ einfo
+ einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
+ einfo
+}
+