summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 16:17:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 16:17:08 +0000
commit58b383f0e7349c1441ecd552c8950aa912d79c1d (patch)
treef3ba42ee95f4ce70a5690d94947c1e8400b8e1da /dev-util/ddd/ddd-3.3.1-r3.ebuild
parentre-add patch (diff)
downloadhistorical-58b383f0e7349c1441ecd552c8950aa912d79c1d.tar.gz
historical-58b383f0e7349c1441ecd552c8950aa912d79c1d.tar.bz2
historical-58b383f0e7349c1441ecd552c8950aa912d79c1d.zip
touchups
Diffstat (limited to 'dev-util/ddd/ddd-3.3.1-r3.ebuild')
-rw-r--r--dev-util/ddd/ddd-3.3.1-r3.ebuild20
1 files changed, 6 insertions, 14 deletions
diff --git a/dev-util/ddd/ddd-3.3.1-r3.ebuild b/dev-util/ddd/ddd-3.3.1-r3.ebuild
index d56c4fc4fec6..c5efdc2d60e8 100644
--- a/dev-util/ddd/ddd-3.3.1-r3.ebuild
+++ b/dev-util/ddd/ddd-3.3.1-r3.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.1-r3.ebuild,v 1.6 2003/03/30 00:36:40 liquidx Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.1-r3.ebuild,v 1.7 2003/04/23 16:13:27 vapier Exp $
inherit eutils
-S="${WORKDIR}/${P}"
-DESCRIPTION="GNU DDD is a graphical front-end for command-line debuggers"
+DESCRIPTION="graphical front-end for command-line debuggers"
HOMEPAGE="http://www.gnu.org/software/ddd"
SRC_URI="ftp://ftp.easynet.be/gnu/ddd/${P}.tar.gz
ftp://ftp.easynet.be/gnu/ddd/${P}-html-manual.tar.gz"
@@ -20,7 +17,6 @@ DEPEND="virtual/x11
>=sys-devel/gdb-4.16
virtual/motif"
-
src_unpack() {
unpack ${A}
@@ -41,7 +37,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
dodir /usr/lib
# If using internal libiberty.a, need to pass
# $tooldir to 'make install', else we get
@@ -50,17 +46,13 @@ src_install () {
einstall tooldir=${D}/usr || die
# This one is from binutils
- if [ -f ${D}/usr/lib/libiberty.a ]
- then
- rm -f ${D}/usr/lib/libiberty.a
- fi
+ [ -f ${D}/usr/lib/libiberty.a ] && rm -f ${D}/usr/lib/libiberty.a
# Remove empty dir ...
rmdir ${D}/usr/lib || :
-
+
mv ${S}/doc/README ${S}/doc/README-DOC
dodoc ANNOUNCE AUTHORS BUGS COPYING* CREDITS INSTALL NEWS* NICKNAMES \
OPENBUGS PROBLEMS README* TIPS TODO
-
+
mv ${S}/doc/* ${D}/usr/share/doc/${PF}
}
-