summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 10:38:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 10:38:07 +0000
commit3f2be35377686d31df5a734264dda7cb03c20d1f (patch)
treeeb0f206e9edf104c22f525e32efb0f82678e058d /dev-util/devhelp
parentAdded GNU GPL version 1 (diff)
downloadhistorical-3f2be35377686d31df5a734264dda7cb03c20d1f.tar.gz
historical-3f2be35377686d31df5a734264dda7cb03c20d1f.tar.bz2
historical-3f2be35377686d31df5a734264dda7cb03c20d1f.zip
repoman'd
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/devhelp-0.4-r1.ebuild63
-rw-r--r--dev-util/devhelp/devhelp-0.4.ebuild62
-rw-r--r--dev-util/devhelp/files/digest-devhelp-0.41
3 files changed, 29 insertions, 97 deletions
diff --git a/dev-util/devhelp/devhelp-0.4-r1.ebuild b/dev-util/devhelp/devhelp-0.4-r1.ebuild
index e1dc3dbd0e8e..d9a1a3c01b21 100644
--- a/dev-util/devhelp/devhelp-0.4-r1.ebuild
+++ b/dev-util/devhelp/devhelp-0.4-r1.ebuild
@@ -1,64 +1,59 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.4-r1.ebuild,v 1.1 2002/07/04 14:45:29 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.4-r1.ebuild,v 1.2 2002/07/23 10:38:07 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Developer help browser"
SRC_URI="http://devhelp.codefactory.se/download/${P}.tar.gz"
HOMEPAGE="http://devhelp.codefactory.se/"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
-RDEPEND=">=gnome-base/gnome-libs-1.4.1.7
+DEPEND=">=gnome-base/gnome-libs-1.4.1.7
>=gnome-base/ORBit-0.5.10-r1
>=gnome-base/bonobo-1.0.19
- ( >=gnome-base/libglade-0.17-r1
- <gnome-base/libglade-2.0.0 )
+ =gnome-base/libglade-0*
>=dev-libs/libxml-1.8.17
>=gnome-extra/gtkhtml-1.0.2
=gnome-base/gconf-1.0*
- ( >=gnome-base/gnome-vfs-1.0.2-r1
- <gnome-base/gnome-vfs-2.0.0 )
+ =gnome-base/gnome-vfs-1*
>=gnome-base/oaf-0.6.8-r1
>=gnome-base/gnome-print-0.30"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=dev-util/intltool-0.11"
+RDEPEND="nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
src_compile() {
local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
+ use nls || myconf="--disable-nls"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --disable-more-warnings \
- --disable-install-schemas \
- --without-python $myconf || die
+ econf \
+ --disable-more-warnings \
+ --disable-install-schemas \
+ --without-python \
+ ${myconf} || die
emake || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
}
pkg_postinst() {
- # This is directly from the rpm specfile for devhelp...
- # Fix gconf permissions
- killall gconfd-1 2>/dev/null >/dev/null
- chmod o+rX /etc/gconf -R
- # Install schemas
- gconftool-1 --shutdown
- SOURCE=xml::/etc/gconf/gconf.xml.defaults
- GCONF_CONFIG_SOURCE=$SOURCE \
- gconftool-1 --makefile-install-rule \
- /etc/gconf/schemas/devhelp.schemas \
- # 2>/dev/null >/dev/null || exit 1
- assert "gconftool-1 execution failed"
+ # This is directly from the rpm specfile for devhelp...
+ # Fix gconf permissions
+ killall gconfd-1 2>/dev/null >/dev/null
+ chmod o+rX /etc/gconf -R
+ # Install schemas
+ gconftool-1 --shutdown
+ SOURCE=xml::/etc/gconf/gconf.xml.defaults
+ GCONF_CONFIG_SOURCE=$SOURCE \
+ gconftool-1 --makefile-install-rule \
+ /etc/gconf/schemas/devhelp.schemas \
+ || "gconftool-1 execution failed"
}
diff --git a/dev-util/devhelp/devhelp-0.4.ebuild b/dev-util/devhelp/devhelp-0.4.ebuild
deleted file mode 100644
index a0e86892cbfd..000000000000
--- a/dev-util/devhelp/devhelp-0.4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.4.ebuild,v 1.2 2002/07/11 06:30:25 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Developer help browser"
-SRC_URI="http://devhelp.codefactory.se/download/${P}.tar.gz"
-HOMEPAGE="http://devhelp.codefactory.se/"
-LICENSE="GPL"
-SLOT="0"
-
-RDEPEND=">=gnome-base/gnome-libs-1.2.8
- >=gnome-base/ORBit-0.5.10-r1
- >=gnome-base/bonobo-1.0.9-r1
- >=gnome-base/libglade-0.17-r1
- >=dev-libs/libxml-1.8.15
- >=gnome-extra/gtkhtml-0.10.0
- >=gnome-base/gconf-1.0.4-r2
- >=gnome-base/gnome-vfs-1.0.2-r1
- >=gnome-base/oaf-0.6.6-r1
- >=gnome-base/gnome-print-0.30"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=dev-util/intltool-0.11"
-
-src_compile() {
- local myconf
-
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --disable-more-warnings \
- --disable-install-schemas \
- --without-python $myconf || die
-
- emake || die
-}
-
-src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog README NEWS TODO
-}
-
-pkg_postinst() {
- # This is directly from the rpm specfile for devhelp...
- # Fix gconf permissions
- killall gconfd-1 2>/dev/null >/dev/null
- chmod o+rX /etc/gconf -R
- # Install schemas
- gconftool-1 --shutdown
- SOURCE=xml::/etc/gconf/gconf.xml.defaults
- GCONF_CONFIG_SOURCE=$SOURCE \
- gconftool-1 --makefile-install-rule \
- /etc/gconf/schemas/devhelp.schemas \
- # 2>/dev/null >/dev/null || exit 1
- assert "gconftool-1 execution failed"
-}
diff --git a/dev-util/devhelp/files/digest-devhelp-0.4 b/dev-util/devhelp/files/digest-devhelp-0.4
deleted file mode 100644
index b851b8dd107c..000000000000
--- a/dev-util/devhelp/files/digest-devhelp-0.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0475b6a225d76173702d26dc05fba278 devhelp-0.4.tar.gz 363429