summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2008-03-22 15:54:47 +0000
committerHarald van Dijk <truedfx@gentoo.org>2008-03-22 15:54:47 +0000
commit7de2a046cd6c3380f9bcb0dc073c2258fbea6152 (patch)
tree51136ecc9c4ee607af445a90703ac3886234b054 /dev-util/dialog/dialog-1.1.20080316.ebuild
parentMarked ppc stable for bug #212361. (diff)
downloadhistorical-7de2a046cd6c3380f9bcb0dc073c2258fbea6152.tar.gz
historical-7de2a046cd6c3380f9bcb0dc073c2258fbea6152.tar.bz2
historical-7de2a046cd6c3380f9bcb0dc073c2258fbea6152.zip
Version bump (bug #214262), remove older versions
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-util/dialog/dialog-1.1.20080316.ebuild')
-rw-r--r--dev-util/dialog/dialog-1.1.20080316.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/dialog/dialog-1.1.20080316.ebuild b/dev-util/dialog/dialog-1.1.20080316.ebuild
new file mode 100644
index 000000000000..81641d82cbde
--- /dev/null
+++ b/dev-util/dialog/dialog-1.1.20080316.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.1.20080316.ebuild,v 1.1 2008/03/22 15:54:47 truedfx Exp $
+
+inherit eutils
+
+MY_PV="${PV/1.1./1.1-}"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="ftp://invisible-island.net/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="examples nls unicode"
+
+RDEPEND=">=app-shells/bash-2.04-r3
+ >=sys-libs/ncurses-5.2-r5"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ eerror "Installing dialog with the unicode flag requires ncurses be"
+ eerror "built with it as well. Please make sure your /etc/make.conf"
+ eerror "or /etc/portage/package.use enables it, and re-install"
+ eerror "ncurses with \`emerge --oneshot sys-libs/ncurses\`."
+ die "Re-emerge ncurses with the unicode flag"
+ fi
+}
+
+src_compile() {
+ use unicode && ncursesw="w"
+ econf $(use_enable nls) \
+ "--with-ncurses${ncursesw}" || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc CHANGES README VERSION
+
+ if use examples; then
+ docinto samples
+ dodoc samples/*
+ fi
+}