summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-10-01 20:20:11 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-10-01 20:20:11 +0000
commitb304778fa754bf57c807a13fef379d691aa639c8 (patch)
tree62361e7e0dc5bb751c95971c3589fc413b805580 /dev-util/diasce/diasce-1.4.ebuild
parentBump (diff)
downloadhistorical-b304778fa754bf57c807a13fef379d691aa639c8.tar.gz
historical-b304778fa754bf57c807a13fef379d691aa639c8.tar.bz2
historical-b304778fa754bf57c807a13fef379d691aa639c8.zip
Bump
Diffstat (limited to 'dev-util/diasce/diasce-1.4.ebuild')
-rw-r--r--dev-util/diasce/diasce-1.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/diasce/diasce-1.4.ebuild b/dev-util/diasce/diasce-1.4.ebuild
new file mode 100644
index 000000000000..bf2c4ba8674d
--- /dev/null
+++ b/dev-util/diasce/diasce-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diasce/diasce-1.4.ebuild,v 1.1 2003/10/01 20:20:05 pyrania Exp $
+
+MY_P=${PN}2-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The C/C++ Code editor for Gnome"
+HOMEPAGE="http://diasce.es.gnome.org/"
+SRC_URI="http://diasce.es.gnome.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+RDEPEND=">=dev-libs/libxml2-2.4
+ >=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gconf-1.2
+ >=gnome-base/libgnomecanvas-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}