summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-02-05 04:09:02 +0000
committerMarius Mauch <genone@gentoo.org>2004-02-05 04:09:02 +0000
commit5660279bff9b2a159ba89354e9f8a94b5d39f999 (patch)
tree4926211081f9009cffcff47dc8b59c6d713fde42 /dev-util/gambas
parentbuh bye amd64 (diff)
downloadhistorical-5660279bff9b2a159ba89354e9f8a94b5d39f999.tar.gz
historical-5660279bff9b2a159ba89354e9f8a94b5d39f999.tar.bz2
historical-5660279bff9b2a159ba89354e9f8a94b5d39f999.zip
version bump, added a doc USE flag and replaced that POS the author calls Makefile
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog15
-rw-r--r--dev-util/gambas/Manifest8
-rw-r--r--dev-util/gambas/files/Makefile.am-0.8235
-rw-r--r--dev-util/gambas/files/digest-gambas-0.821
-rw-r--r--dev-util/gambas/files/non-symlink-0.82.patch64
-rw-r--r--dev-util/gambas/gambas-0.72.ebuild4
-rw-r--r--dev-util/gambas/gambas-0.82.ebuild70
7 files changed, 190 insertions, 7 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index f0cf47a2ea2f..b042fd21850a 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,15 @@
-# ChangeLog for dev-util/gambas
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.2 2003/12/02 07:13:39 genone Exp $
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.3 2004/02/05 04:09:02 genone Exp $
+
+*gambas-0.82 (05 Feb 2004)
+
+ 05 Feb 2004; Marius Mauch <genone@gentoo.org> gambas-0.82.ebuild,
+ files/Makefile.am-0.82, files/non-symlink-0.82.patch:
+ version bump. Added --enable-optimization swtich to configure, still have to
+ patch it so it uses the CFLAGS from make.conf. Made API docs and examples
+ depend on the "doc" USE flag and install them in the right location.
+ Replaced the Makefile patching with regenerating it from a new Makefile.am
*gambas-0.72 (02 Dec 2003)
diff --git a/dev-util/gambas/Manifest b/dev-util/gambas/Manifest
index 9f05c0681a40..2e2e267dc04f 100644
--- a/dev-util/gambas/Manifest
+++ b/dev-util/gambas/Manifest
@@ -1,5 +1,9 @@
-MD5 418b7558312b8dfa503bde489b43f61b gambas-0.72.ebuild 1560
-MD5 d1680457a92a279eb0e33f2b99a1ac46 ChangeLog 622
+MD5 897e731af30d058e1abacadf7aad669b gambas-0.82.ebuild 2085
+MD5 eb1e204967caa2cc1fb4559c8348e3dd gambas-0.72.ebuild 1560
+MD5 4de122624c4918d910398e12dd5ad5d5 ChangeLog 1089
MD5 622720c5c5e309d4457ff037f8a4175f metadata.xml 222
+MD5 30893adf8f34f69b90fa4e9e736b579b files/non-symlink-0.82.patch 1489
MD5 ae2d9d9ca26d8cd07432890ecf5fe206 files/digest-gambas-0.72 65
+MD5 2116ae384517062671a599bd0969c9ea files/digest-gambas-0.82 65
+MD5 6ec007ea84b18c31ebad9e5403ad3835 files/Makefile.am-0.82 1242
MD5 7823ef6207c12562fe6e3b0069fce980 files/non-symlink-0.72.patch 1631
diff --git a/dev-util/gambas/files/Makefile.am-0.82 b/dev-util/gambas/files/Makefile.am-0.82
new file mode 100644
index 000000000000..d1a1b53d2097
--- /dev/null
+++ b/dev-util/gambas/files/Makefile.am-0.82
@@ -0,0 +1,35 @@
+SUBDIRS = libltdl src
+EXTRA_DIST = TODO reconf app examples help README.REDHAT
+##AUTOMAKE_OPTIONS = dist-bzip2
+
+install-exec-local:
+ @echo
+ @echo "Installing the development environment..."
+ @(cd $(srcdir)/app; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
+ gbc -ag; gba; rm -rf .gambas; $(INSTALL) $$p $(bindir); done)
+
+ @echo
+ @echo "Creating the library info files..."
+ @$(INSTALL) -d $(libdir)/info
+ @$(bindir)/gbi -a
+ @rm -f $(libdir)/lib.gb.la
+ @rm -f $(libdir)/lib.gb.so*
+
+ @echo
+ @echo "Installing the gambas help files..."
+ @$(INSTALL) -d $(datadir)/help
+ @rm -rf $(datadir)/help
+ @cp -R $(srcdir)/help $(datadir)
+
+ @echo
+ @echo "Installing the gambas examples..."
+ @rm -rf $(datadir)/examples
+ @$(INSTALL) -d $(datadir)/examples
+ @cp -R $(srcdir)/examples $(datadir)
+ @(cd $(datadir)/examples; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
+ gbc -ag; gba; done)
+
+dist-hook:
+ @(cd $(distdir)/app; for p in *; do rm -rf $$p/.gambas $$p/.xvpics $$p/*/.xvpics $$p/*/*/.xvpics $$p/*~ $$p/.*.out $$p/*.out $$p/.lang/*.pot $$p/$$p; done)
+ @(cd $(distdir)/examples; for p in *; do rm -rf $$p/.gambas $$p/.xvpics $$p/*/.xvpics $$p/*/*/.xvpics $$p/*~ $$p/.*.out $$p/*.out $$p/.lang/*.pot $$p/$$p; done)
+
diff --git a/dev-util/gambas/files/digest-gambas-0.82 b/dev-util/gambas/files/digest-gambas-0.82
new file mode 100644
index 000000000000..5be0d65da2ca
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.82
@@ -0,0 +1 @@
+MD5 c3afb5b9b94c25f272070bf910633655 gambas-0.82.tar.bz2 2606284
diff --git a/dev-util/gambas/files/non-symlink-0.82.patch b/dev-util/gambas/files/non-symlink-0.82.patch
new file mode 100644
index 000000000000..d36d2a5607c9
--- /dev/null
+++ b/dev-util/gambas/files/non-symlink-0.82.patch
@@ -0,0 +1,64 @@
+--- src/comp/gbi.c.org 2003-10-27 21:51:41.000000000 +0100
++++ src/comp/gbi.c 2003-11-17 23:41:29.000000000 +0100
+@@ -54,6 +54,34 @@
+ #include "str.h"
+ #include "gambas.h"
+
++/* needed to install in a different location than /usr */
++char *which(const char *app)
++{
++ char *path = NULL;
++ char *p = NULL;
++ char *rValue = NULL;
++
++ path = getenv("PATH");
++ if (!path) {
++ path = "/usr/bin/";
++ }
++ p = strtok(strdup(path), ":");
++ while (p) {
++ rValue = (char *)calloc(sizeof(char), strlen(p)+strlen(app)+2);
++ strcat(rValue, p);
++ rValue[strlen(p)] = '/';
++ strcat(rValue, app);
++ rValue[strlen(p)+1+strlen(app)] = '\0';
++ if (access(rValue, X_OK) == 0) {
++ return rValue;
++ }
++ p = strtok(NULL, ":");
++ free(rValue);
++ rValue = NULL;
++ }
++ return NULL;
++}
++
+
+ PRIVATE char _lib_path[MAX_PATH + 1];
+ PRIVATE FILE *out;
+@@ -102,7 +129,7 @@
+
+ /* chemin d'installation de Gambas */
+
+- path = FILE_readlink(GAMBAS_LINK_PATH);
++ path = which("gbx");
+ if (!path)
+ {
+ path = GAMBAS_LINK_PATH;
+@@ -422,7 +450,7 @@
+ if (strcmp(name, "gb") == 0)
+ {
+ sprintf(path, LIB_PATTERN, _lib_path, name);
+- dlib = dlopen("/usr/bin/gbx", RTLD_NOW);
++ dlib = dlopen(which("gbx"), RTLD_NOW);
+ if (!dlib)
+ error2("Cannot open component:", dlerror());
+
+@@ -472,7 +500,7 @@
+ sprintf(buf, "LD_PRELOAD=%s", lib);
+ putenv(buf);
+ putenv("GAMBAS_PRELOAD=1");
+- execv("/usr/bin/gbi", argv);
++ execvp("gbi", argv);
+ #endif
+ }
+
diff --git a/dev-util/gambas/gambas-0.72.ebuild b/dev-util/gambas/gambas-0.72.ebuild
index 9830ca113461..0747b220adb5 100644
--- a/dev-util/gambas/gambas-0.72.ebuild
+++ b/dev-util/gambas/gambas-0.72.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.72.ebuild,v 1.1 2003/12/02 07:13:39 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.72.ebuild,v 1.2 2004/02/05 04:09:02 genone Exp $
DESCRIPTION="a RAD tool for BASIC"
diff --git a/dev-util/gambas/gambas-0.82.ebuild b/dev-util/gambas/gambas-0.82.ebuild
new file mode 100644
index 000000000000..1b6881588761
--- /dev/null
+++ b/dev-util/gambas/gambas-0.82.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.82.ebuild,v 1.1 2004/02/05 04:09:02 genone Exp $
+
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="kde postgres mysql sdl"
+DEPEND=">=sys-devel/automake-1.7.5
+ >=sys-devel/autoconf-2.57
+ >=x11-base/xfree-4.3.0
+ >=x11-libs/qt-3.1
+ kde? ( >=kde-base/kdelibs-3.1 )
+ sdl? ( media-libs/libsdl )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-${PV}" ./Makefile.am
+ automake
+ autoconf
+ epatch ${FILESDIR}/non-symlink-${PV}.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} `use_with kde kde-includes ${KDEDIR}/include`"
+ myconf="${myconf} `use_with mysql mysql-includes /usr/include/mysql`"
+ myconf="${myconf} `use_with postgres postgresql-includes /usr/include/postgresql/server`"
+ myconf="${myconf} `use_with sdl sdl-includes /usr/include/SDL`"
+
+ econf ${myconf} --enable-optimization || die
+
+ use kde || sed -i "s:#define HAVE_KDE_COMPONENT 1:#undef HAVE_KDE_COMPONENT:" config.h
+ use mysql || sed -i "s:#define HAVE_MYSQL_COMPONENT 1:#undef HAVE_MYSQL_COMPONENT:" config.h
+ use postgres || sed -i "s:#define HAVE_PGSQL_COMPONENT 1:#undef HAVE_PGSQL_COMPONENT:" config.h
+ use sdl || sed -i "s:#define HAVE_SDL_COMPONENT 1:#undef HAVE_SDL_COMPONENT:" config.h
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ einstall || die
+
+ dodoc README INSTALL AUTHORS ChangeLog COPYING TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
+ einfo "Compiling examples ..."
+ cd ${D}/usr/share/doc/${PF}/examples
+ for p in *; do
+ cd $p
+ gbc -ag
+ gba
+ cd ..
+ done
+ fi
+ rm -rf ${D}/usr/share/help ${D}/usr/share/examples
+}