summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2006-07-06 17:18:29 +0000
committerRob Cakebread <pythonhead@gentoo.org>2006-07-06 17:18:29 +0000
commit381f3ea7b40f66e0602af996188f911660825a66 (patch)
treea584b6beb35c6a5ddc79bc8bbaa3dadaf9461da9 /dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild
parentInitial version. (diff)
downloadhistorical-381f3ea7b40f66e0602af996188f911660825a66.tar.gz
historical-381f3ea7b40f66e0602af996188f911660825a66.tar.bz2
historical-381f3ea7b40f66e0602af996188f911660825a66.zip
amd64 patch and ebuild fix submitted by Yogesh <ysharma@catprosystems.com>
Package-Manager: portage-2.1.1_pre2-r4
Diffstat (limited to 'dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild')
-rw-r--r--dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild b/dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..78d1526c717a
--- /dev/null
+++ b/dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gazpacho/gazpacho-0.6.2-r1.ebuild,v 1.1 2006/07/06 17:18:28 pythonhead Exp $
+
+inherit distutils gnome.org eutils
+
+DESCRIPTION="Gazpacho is a glade-like gtk interface designer."
+HOMEPAGE="http://gazpacho.sicem.biz/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ >=gnome-base/libglade-2.4.2"
+
+DOCS="AUTHORS NEWS"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-setup-fixes.patch"
+ epatch "${FILESDIR}/${P}-amd64-fixes.patch"
+
+ # In an attempt to make the above patch reusable across gazpacho
+ # versions it patched in EBUILD_PF_HERE and EBUILD_PV_HERE markers
+ # instead of hardcoding version numbers in the patch.
+ sed -i -e "s/EBUILD_PF_HERE/${PF}/" \
+ -e "s/EBUILD_PV_HERE/${PV}/" \
+ setup.py
+}
+
+src_install() {
+ distutils_src_install
+ docinto internals
+ dodoc doc/*
+ insinto /usr/share/doc/${PF}
+ # these are needed in un-gzipped form or the "about" box crashes
+ doins AUTHORS CONTRIBUTORS COPYING
+ rm "${D}"/usr/share/doc/${PF}/{AUTHORS,CONTRIBUTORS}.gz
+}