summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-12-25 08:57:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-12-25 08:57:27 +0000
commit6e028c453c900137070f1f69773e710eb4f4ba23 (patch)
treec84342a2e8cccb2a85700c3611bccdcb10fbdca4 /dev-util/git/git-1.5.3.7-r1.ebuild
parentAdd latest rc from upstream. (diff)
downloadhistorical-6e028c453c900137070f1f69773e710eb4f4ba23.tar.gz
historical-6e028c453c900137070f1f69773e710eb4f4ba23.tar.bz2
historical-6e028c453c900137070f1f69773e710eb4f4ba23.zip
Bug 201544: Use the proper build mechanism to disable the Tk-using sections of git.
Package-Manager: portage-2.1.4_rc10
Diffstat (limited to 'dev-util/git/git-1.5.3.7-r1.ebuild')
-rw-r--r--dev-util/git/git-1.5.3.7-r1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-util/git/git-1.5.3.7-r1.ebuild b/dev-util/git/git-1.5.3.7-r1.ebuild
index 83328466e706..ae32ca36a8a7 100644
--- a/dev-util/git/git-1.5.3.7-r1.ebuild
+++ b/dev-util/git/git-1.5.3.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.3.7-r1.ebuild,v 1.5 2007/12/25 08:39:00 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.3.7-r1.ebuild,v 1.6 2007/12/25 08:57:27 robbat2 Exp $
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
@@ -59,6 +59,7 @@ exportmakeopts() {
myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+ use tk || myopts="${myopts} NO_TCLTK=YesPlease"
export MY_MAKEOPTS=${myopts}
}
@@ -107,8 +108,6 @@ src_install() {
emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || \
die "make install failed"
- use tk || rm "${D}"/usr/bin/git{k,-gui}
-
doman man?/*
dodoc README Documentation/{SubmittingPatches,CodingGuidelines}