summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-19 19:30:36 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-19 19:30:36 +0000
commit87e871f550c1b1839be6a0a8640f682e0e072355 (patch)
treec008a4531da38eb923454646058a2e4228e4f8bc /dev-util/gnustep-guile
parentSome packages got remasked after (I'd assume) the recent package.mask screwup... (diff)
downloadhistorical-87e871f550c1b1839be6a0a8640f682e0e072355.tar.gz
historical-87e871f550c1b1839be6a0a8640f682e0e072355.tar.bz2
historical-87e871f550c1b1839be6a0a8640f682e0e072355.zip
Initial gnustep-guile ebuild.
Diffstat (limited to 'dev-util/gnustep-guile')
-rw-r--r--dev-util/gnustep-guile/ChangeLog11
-rw-r--r--dev-util/gnustep-guile/files/digest-gnustep-guile-1.0.31
-rw-r--r--dev-util/gnustep-guile/files/installpath.diff12
-rw-r--r--dev-util/gnustep-guile/gnustep-guile-1.0.3.ebuild41
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/gnustep-guile/ChangeLog b/dev-util/gnustep-guile/ChangeLog
new file mode 100644
index 000000000000..4e7860d23a9c
--- /dev/null
+++ b/dev-util/gnustep-guile/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-guile/ChangeLog,v 1.1 2002/07/19 19:30:36 raker Exp $
+
+*gnustep-guile-1.0.3 (19 Jul 2002)
+
+ 19 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ gnustep-guile-1.0.3.ebuild, files/digest-gnustep-guile-1.0.3,
+ files/installpath.diff :
+
+ Initial ebuild of gnustep-guile.
diff --git a/dev-util/gnustep-guile/files/digest-gnustep-guile-1.0.3 b/dev-util/gnustep-guile/files/digest-gnustep-guile-1.0.3
new file mode 100644
index 000000000000..8e00a2c07e24
--- /dev/null
+++ b/dev-util/gnustep-guile/files/digest-gnustep-guile-1.0.3
@@ -0,0 +1 @@
+MD5 2107a7fdb29225329e6257448ac95371 gnustep-guile-1.0.3.tar.gz 318049
diff --git a/dev-util/gnustep-guile/files/installpath.diff b/dev-util/gnustep-guile/files/installpath.diff
new file mode 100644
index 000000000000..739608e970b2
--- /dev/null
+++ b/dev-util/gnustep-guile/files/installpath.diff
@@ -0,0 +1,12 @@
+diff -urN gnustep-guile-1.0.3/Library/Makefile.postamble gnustep-guile-1.0.3-modified/Library/Makefile.postamble
+--- gnustep-guile-1.0.3/Library/Makefile.postamble Sat Jan 5 00:05:56 2002
++++ gnustep-guile-1.0.3-modified/Library/Makefile.postamble Fri Jul 19 14:24:57 2002
+@@ -27,7 +27,7 @@
+ # library to that the <libname>.so symlink points to. That should be the
+ # shared object name of the library.
+ after-install::
+- @DIRP=$(GNUSTEP_SYSTEM_ROOT)/Libraries/Guile; \
++ @DIRP=${D}/usr/GNUstep/System/Libraries/Guile; \
+ $(MKINSTALLDIRS) $$DIRP/languages/gstep-guile; \
+ for i in $(SCHEME_FILES); do \
+ $(INSTALL_DATA) $$i $$DIRP/languages/$$i; \
diff --git a/dev-util/gnustep-guile/gnustep-guile-1.0.3.ebuild b/dev-util/gnustep-guile/gnustep-guile-1.0.3.ebuild
new file mode 100644
index 000000000000..dfdb7582b140
--- /dev/null
+++ b/dev-util/gnustep-guile/gnustep-guile-1.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-guile/gnustep-guile-1.0.3.ebuild,v 1.1 2002/07/19 19:30:36 raker Exp $
+
+DESCRIPTION="GNUstep Guile bridge"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND=">=dev-util/gnustep-base-1.3.4
+ >=dev-util/guile-1.4-r3"
+RDEPEND="virtual/glibc"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ # Source GNUstep Makefiles
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ # No options are needed to configure as environment variables
+ # are pulled from the GNUstep Makefiles
+ ./configure || die "configure failed"
+
+ # Parallel builds fail on gnustep-base so I will follow suit here
+ make || die "make failed"
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/installpath.diff
+ cd ${S}
+
+ make INSTALL_ROOT_DIR=${D} \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ install || die "install failed"
+
+}