summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-20 22:31:17 +0000
committerChris White <chriswhite@gentoo.org>2005-11-20 22:31:17 +0000
commitf07639caca65c8b9186e62676870ad33b5c3ee3e (patch)
tree889775ad229b7c52343cfa9ab7489843dc681c82 /dev-util/jam/jam-2.5-r3.ebuild
parentStable on alpha wrt security bug #112482 (diff)
downloadhistorical-f07639caca65c8b9186e62676870ad33b5c3ee3e.tar.gz
historical-f07639caca65c8b9186e62676870ad33b5c3ee3e.tar.bz2
historical-f07639caca65c8b9186e62676870ad33b5c3ee3e.zip
Revision bump to -r3 to force upgrade for fix in bug #103893. Removed old -r2.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'dev-util/jam/jam-2.5-r3.ebuild')
-rw-r--r--dev-util/jam/jam-2.5-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/jam/jam-2.5-r3.ebuild b/dev-util/jam/jam-2.5-r3.ebuild
new file mode 100644
index 000000000000..94a9183fc66b
--- /dev/null
+++ b/dev-util/jam/jam-2.5-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/jam-2.5-r3.ebuild,v 1.1 2005/11/20 22:31:17 chriswhite Exp $
+
+inherit eutils
+
+DESCRIPTION="Just Another Make - advanced make replacement"
+HOMEPAGE="http://www.perforce.com/jam/jam.html"
+SRC_URI="ftp://ftp.perforce.com/pub/jam/${P}.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/bison
+ !dev-util/boost-jam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cxx.patch
+ epatch "${FILESDIR}"/${P}-amd64.patch
+ epatch "${FILESDIR}"/${P}-dependency.patch
+}
+
+src_compile() {
+ # The bootstrap makefile assumes ${S} is in the path
+ env PATH="${PATH}:${S}" \
+ emake -j1 \
+ YACC="bison -y" \
+ CFLAGS="${CFLAGS}" \
+ || die
+}
+
+src_install() {
+ BINDIR="${D}/usr/bin" ./jam0 install || die
+ dohtml Jam.html Jambase.html Jamfile.html
+ dodoc README RELNOTES Porting
+}