summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-10-23 22:48:16 +0000
committerStefan Jones <cretin@gentoo.org>2003-10-23 22:48:16 +0000
commit9c24b413e9023d50bde5efd1664d3b8c70b10bbd (patch)
tree3a2d7d2a49b29470660721bb969f0d020b091e26 /dev-util/oprofile/oprofile-0.7.ebuild
parentminor fix (diff)
downloadhistorical-9c24b413e9023d50bde5efd1664d3b8c70b10bbd.tar.gz
historical-9c24b413e9023d50bde5efd1664d3b8c70b10bbd.tar.bz2
historical-9c24b413e9023d50bde5efd1664d3b8c70b10bbd.zip
New ebuild
Diffstat (limited to 'dev-util/oprofile/oprofile-0.7.ebuild')
-rw-r--r--dev-util/oprofile/oprofile-0.7.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/oprofile/oprofile-0.7.ebuild b/dev-util/oprofile/oprofile-0.7.ebuild
new file mode 100644
index 000000000000..7b3ea5dadc20
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.ebuild,v 1.1 2003/10/23 22:48:16 cretin Exp $
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt"
+DEPEND="
+ >=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt? ( >=x11-libs/qt-3.2.1-r2 )"
+
+src_compile() {
+ check_KV
+
+ local myconf=""
+
+ myconf="${myconf} --with-x"
+ # note: compilation has only been tested with a 2.4 kernel
+ case $KV in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '$KV' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ # media-video/nvidia-kernel does the following:
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo "Now load the oprofile module by running:"
+ einfo " # opcontrol --init"
+ einfo "Then read manpages and this html doc:"
+ einfo " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}