summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-04 15:59:32 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-04 15:59:32 +0000
commit3089435f0c1b1ab8122b08774c2caedc7aaf17a0 (patch)
treee54532b7f9709ade00db1da09436c20e9b7e2614 /dev-util/patchelf/files
parentRaise the opencv dependency. (diff)
downloadhistorical-3089435f0c1b1ab8122b08774c2caedc7aaf17a0.tar.gz
historical-3089435f0c1b1ab8122b08774c2caedc7aaf17a0.tar.bz2
historical-3089435f0c1b1ab8122b08774c2caedc7aaf17a0.zip
dev-util/patchelf: Use system header, thanks fedora; respect CC, CFLAGS and LDFLAGS in test binaries
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'dev-util/patchelf/files')
-rw-r--r--dev-util/patchelf/files/patchelf-0.6-test-build.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/patchelf/files/patchelf-0.6-test-build.patch b/dev-util/patchelf/files/patchelf-0.6-test-build.patch
new file mode 100644
index 000000000000..0b4dc90b0082
--- /dev/null
+++ b/dev-util/patchelf/files/patchelf-0.6-test-build.patch
@@ -0,0 +1,55 @@
+ tests/Makefile.am | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 9d9b6bc..effde41 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -12,37 +12,37 @@ main_scoped_SOURCES =
+
+
+ main: main.o libfoo.so
+- LD_LIBRARY_PATH=. gcc -Wl,--disable-new-dtags -o main main.o -L . -lfoo
++ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o main main.o -L . -lfoo
+
+ main-scoped: main.o libfoo-scoped.so
+- LD_LIBRARY_PATH=. gcc -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped
++ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped
+
+ main.o: main.c
+- $(CC) -fpic -o main.o -c main.c
++ $(CC) $(CFLAGS) -fpic -o main.o -c main.c
+
+ libfoo.so: foo.o libbar.so
+- NIX_DONT_SET_RPATH=1 $(CC) -Wl,--disable-new-dtags -shared -o libfoo.so foo.o -L . -lbar
++ NIX_DONT_SET_RPATH=1 $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -shared -o libfoo.so foo.o -L . -lbar
+
+ libfoo-scoped.so: foo.o libbar-scoped.so
+- NIX_DONT_SET_RPATH=1 $(CC) -Wl,--enable-new-dtags -shared -o libfoo-scoped.so foo.o -L . -lbar-scoped
++ NIX_DONT_SET_RPATH=1 $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--enable-new-dtags -shared -o libfoo-scoped.so foo.o -L . -lbar-scoped
+
+ foo.o: foo.c
+- $(CC) -fpic -o foo.o -c foo.c
++ $(CC) $(CFLAGS) -fpic -o foo.o -c foo.c
+
+ libbar.so: bar.o
+- NIX_DONT_SET_RPATH=1 $(CC) -Wl,--disable-new-dtags -shared -o libbar.so bar.o -L . -Wl,-rpath,`pwd`/no-such-path
++ NIX_DONT_SET_RPATH=1 $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -shared -o libbar.so bar.o -L . -Wl,-rpath,`pwd`/no-such-path
+
+ libbar-scoped.so: bar.o
+- NIX_DONT_SET_RPATH=1 $(CC) -Wl,--enable-new-dtags -shared -o libbar-scoped.so bar.o
++ NIX_DONT_SET_RPATH=1 $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--enable-new-dtags -shared -o libbar-scoped.so bar.o
+
+ bar.o: bar.c
+- $(CC) -fpic -o bar.o -c bar.c
++ $(CC) $(CFLAGS) -fpic -o bar.o -c bar.c
+
+
+ big_dynstr_SOURCES = big-dynstr.c
+
+ big-dynstr: big-dynstr.o libfoo.so
+- LD_LIBRARY_PATH=. gcc -Wl,--disable-new-dtags -o big-dynstr big-dynstr.o -L . -lfoo
++ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o big-dynstr big-dynstr.o -L . -lfoo
+
+ big-dynstr.c: main.c
+ cat main.c > big-dynstr.c