summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-24 00:29:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-24 00:29:54 +0000
commitc43d2e86c0409043b2ed8b3e1555a17f6166bbc5 (patch)
tree0f30f496fd81fecc06556a4397556cc32677a711 /dev-util/strace/strace-4.5.11.ebuild
parentold (diff)
downloadhistorical-c43d2e86c0409043b2ed8b3e1555a17f6166bbc5.tar.gz
historical-c43d2e86c0409043b2ed8b3e1555a17f6166bbc5.tar.bz2
historical-c43d2e86c0409043b2ed8b3e1555a17f6166bbc5.zip
Version bump #93657 by Diego Pettenò.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util/strace/strace-4.5.11.ebuild')
-rw-r--r--dev-util/strace/strace-4.5.11.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/strace/strace-4.5.11.ebuild b/dev-util/strace/strace-4.5.11.ebuild
new file mode 100644
index 000000000000..1979551a5dd2
--- /dev/null
+++ b/dev-util/strace/strace-4.5.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.11.ebuild,v 1.1 2005/05/24 00:29:54 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Remove some obsolete ia64-related hacks from the strace source
+ # (08 Feb 2005 agriffis)
+ epatch ${FILESDIR}/strace-4.5.8-ia64.patch
+
+ # This is ugly but linux26-headers-2.6.8.1-r2 (and other versions) has some
+ # issues with definition of s64 and friends. This seems to solve
+ # compilation in this case (08 Feb 2005 agriffis)
+ use ia64 && append-flags -D_ASM_IA64_PAL_H
+
+ # Compile fails with -O3 on sparc but works on x86
+ use sparc && replace-flags -O[3-9] -O2
+ filter-lfs-flags
+
+ use static && append-ldflags -static
+}
+
+src_install() {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace strace-graph || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}