summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-10-07 17:07:50 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-10-07 17:07:50 +0000
commit3808e875b1884ac9a5cf50c3b268bbf2cefb762f (patch)
treecbee2d05dc1c50d1e83e85ec19f34fe3de05a153 /dev-util
parentfixing url for truecombat-1.0to1.0a.zip (diff)
downloadhistorical-3808e875b1884ac9a5cf50c3b268bbf2cefb762f.tar.gz
historical-3808e875b1884ac9a5cf50c3b268bbf2cefb762f.tar.bz2
historical-3808e875b1884ac9a5cf50c3b268bbf2cefb762f.zip
Fixes #65962.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog9
-rw-r--r--dev-util/eclipse-sdk/Manifest4
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-3.0.1-r1.ebuild405
-rw-r--r--dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.0.1-r11
4 files changed, 417 insertions, 2 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index 7b35f0dfb2b2..fc340c077a02 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.65 2004/09/23 19:45:06 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.66 2004/10/07 17:07:50 karltk Exp $
+
+*eclipse-sdk-3.0.1-r1 (07 Oct 2004)
+
+ 07 Oct 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-sdk-3.0.1-r1.ebuild:
+ Added support for multiple KDEs. Added amd64 patch by
+ Dan <dan@intuitivelyobvious.net>, fixes #65962.
23 Sep 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
eclipse-sdk-3.1_pre1.ebuild:
diff --git a/dev-util/eclipse-sdk/Manifest b/dev-util/eclipse-sdk/Manifest
index d91624986282..a93ddd5ddb04 100644
--- a/dev-util/eclipse-sdk/Manifest
+++ b/dev-util/eclipse-sdk/Manifest
@@ -2,8 +2,9 @@ MD5 72c647b7fb61acb5f2197480a18c3691 eclipse-sdk-3.0.1.ebuild 11876
MD5 dd291d4c0877638b7b4d263444fab68f eclipse-sdk-3.0.0-r3.ebuild 12074
MD5 0a5769650d0426952026be3b479480ed eclipse-sdk-2.1.3-r3.ebuild 9061
MD5 59b1c127562221294c69eb2ac3f976ca eclipse-sdk-2.1.3-r5.ebuild 9686
+MD5 15a1e55d4a1adcea5951726f024e8ae4 eclipse-sdk-3.0.1-r1.ebuild 13461
MD5 3b77ea6dd08b71b83872d31d9d79e1ab eclipse-sdk-3.1_pre1.ebuild 12127
-MD5 e9daf8ea109f515d2186d6e22fa2342c ChangeLog 12972
+MD5 3ed24f81ad4203cdd9bdf1d977cea46b ChangeLog 13205
MD5 9cc8d5162e981d7b7fc1ef9fa1ac0e65 metadata.xml 919
MD5 ab0f6620b4767e065bd533b06245b0fc files/01-distribute_ant_target-2.1.patch 1103
MD5 6c2995197ef0a038015ffff1dee7ac72 files/00-refactor_rename.patch 59577
@@ -11,6 +12,7 @@ MD5 69ee2069b0260e40c6fa93315ff759cc files/eclipse-3.1.desktop 226
MD5 6ac05b530442f845b10b830e624ffe04 files/eclipse-2.desktop 222
MD5 a8bdecb6304c91da92a3b153e154f544 files/02-konqueror_help_browser-3.0.patch 1560
MD5 0e815a2260dbd0153de35c6de26fbd05 files/digest-eclipse-sdk-3.0.0-r3 86
+MD5 486d232cbe9d4b75d915bb6bf8b5f0d2 files/digest-eclipse-sdk-3.0.1-r1 88
MD5 486d232cbe9d4b75d915bb6bf8b5f0d2 files/digest-eclipse-sdk-3.0.1 88
MD5 eb74cc6c76bd05234e01af4fe0097b0c files/digest-eclipse-sdk-3.1_pre1 88
MD5 ed33fd609db26b85ef9b0c2a82a06b22 files/01-distribute_ant_target-3.0.patch 726
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-3.0.1-r1.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..0362b90934d7
--- /dev/null
+++ b/dev-util/eclipse-sdk/eclipse-sdk-3.0.1-r1.ebuild
@@ -0,0 +1,405 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.0.1-r1.ebuild,v 1.1 2004/10/07 17:07:50 karltk Exp $
+
+inherit eutils java-utils
+
+# karltk: Portage 2.0.51_pre13 needs this
+MY_A="eclipse-sourceBuild-srcIncluded-3.0.1.zip"
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download2.eclipse.org/downloads/drops/R-3.0.1-200409161125/${MY_A}"
+IUSE="gtk motif gnome kde mozilla"
+SLOT="3"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+RDEPEND="|| ( >=virtual/jdk-1.4.2 =dev-java/blackdown-jdk-1.4.2* )
+ gtk? ( >=x11-libs/gtk+-2.2.4 )
+ !gtk? ( kde? ( kde-base/kdelibs x11-libs/openmotif )
+ !kde? ( motif? ( x11-libs/openmotif )
+ !motif? ( >=x11-libs/gtk+-2.2.4 )
+ )
+ )
+ mozilla? ( >=net-www/mozilla-1.5 )
+ gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
+ !media-fonts/unifont"
+
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.5.3
+ >=sys-apps/findutils-4.1.7
+ >=app-shells/tcsh-6.11
+ app-arch/unzip
+ app-arch/zip"
+
+pkg_setup() {
+ if use ppc; then
+ ewarn "This package needs 1 gig Ram on PPC !"
+ fi
+
+ java-utils_setup-vm
+
+ # karltk: refactor, put in java-pkg.eclass?
+ local version="$(java-config --java-version | grep 'java version' | sed -r 's/java version \"(.*)\"/\1/')"
+ local ver_rx="([0-9]+)\.([0-9]+)\.([0-9]+)(.*)"
+ local major=$(echo ${version} | sed -r "s/${ver_rx}/\1/")
+ local minor=$(echo ${version} | sed -r "s/${ver_rx}/\2/")
+ local patch=$(echo ${version} | sed -r "s/${ver_rx}/\3/")
+ local extra=$(echo ${version} | sed -r "s/${ver_rx}/\4/")
+
+ if [ ${major} -ge 1 ] && [ ${minor} -gt 4 ] ; then
+ einfo "Detected JDK is sufficient to compile Eclipse (${version} >= 1.4.2)"
+ elif [ ${major} -ge 1 ] && [ ${minor} -ge 4 ] && [ ${patch} -ge 2 ] ; then
+ einfo "Detected JDK is sufficient to compile Eclipse (${version} >= 1.4.2)"
+ else
+ die "Detected JDK (${version}) is too old to compile Eclipse, need at least 1.4.2!"
+ fi
+
+ if ${use_gtk} && use mozilla ; then
+ if [ -f ${ROOT}/usr/lib/mozilla/libgtkembedmoz.so ] ; then
+ einfo "Compiling against net-www/mozilla"
+ mozilla_dir=/usr/lib/mozilla
+ elif [ -f ${ROOT}/usr/lib/MozillaFirefox/libgtkembedmoz.so ] ; then
+ einfo "Compiling against net-www/mozilla-firefox"
+ mozilla_dir=/usr/lib/MozillaFirefox
+ else
+ eerror "You need either Mozilla, compiled against gtk+ v2.0 or newer"
+ eerror "To merge it, do USE=\"gtk2\" emerge mozilla."
+ eerror "Otherwise, remove \"mozilla\" from use flags"
+ die "Need Mozilla compiled with gtk+-2.0 support"
+ fi
+ fi
+
+ set_dirs
+ use gtk && use_gtk='true' || use_gtk='false'
+ use motif && use_motif='true' || use_motif='false'
+
+ # If gtk+ enabled, disable motif
+ ${use_gtk} && use_motif='false'
+
+ # If neither enabled, default to gtk+
+ ${use_gtk} || ${use_motif} || use_gtk='true'
+}
+
+set_dirs() {
+ gtk_launcher_src_dir="plugins/platform-launcher/library/gtk"
+ motif_launch_src_dir="plugins/platform-launcher/library/motif"
+ gtk_swt_src_dir="plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library"
+ motif_swt_src_dir="plugins/org.eclipse.swt/Eclipse SWT PI/motif/library"
+
+ core_src_dir="plugins/org.eclipse.core.resources.linux/src"
+
+ case $ARCH in
+ sparc)
+ gtk_swt_dest_dir="plugins/org.eclipse.swt.gtk/os/solaris/sparc"
+ motif_swt_dest_dir="plugins/org.eclipse.swt.motif/os/solaris/sparc"
+ core_dest_dir="plugins/org.eclipse.core.resources.linux/os/solaris/sparc"
+ ;;
+ x86)
+ gtk_swt_dest_dir="plugins/org.eclipse.swt.gtk/os/linux/x86"
+ motif_swt_dest_dir="plugins/org.eclipse.swt.motif/os/linux/x86"
+ core_dest_dir="plugins/org.eclipse.core.resources.linux/os/linux/x86"
+ ;;
+ ppc)
+ gtk_swt_dest_dir="plugins/org.eclipse.swt.gtk/os/linux/ppc"
+ motif_swt_dest_dir="plugins/org.eclipse.swt.motif/os/linux/ppc"
+ core_dest_dir="plugins/org.eclipse.core.resources.linux/os/linux/ppc/"
+ ;;
+ amd64)
+ gtk_swt_dest_dir="plugins/org.eclipse.swt.gtk64/os/linux/amd64"
+ motif_swt_dest_dir="plugins/org.eclipse.swt.motif/os/linux/amd64"
+ core_dest_dir="plugins/org.eclipse.core.resources.linux/os/linux/amd64"
+ ;;
+ esac
+}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${MY_A} || die "Could not unpack ${MY_A}"
+
+ epatch ${FILESDIR}/03-motif-java1.5-build.patch
+
+ java-utils_setup-vm
+
+ # Turn off verbose mode and on errors in all build.xml files
+ for x in $(find . -type f -name "build.xml") ; do
+ sed -i -r \
+ -e 's/failonerror="[^"]+"/failonerror="true"/' \
+ -e 's/verbose="[^"]+"/verbose="false"/' $x
+ done
+
+ # Clean up all pre-built code
+ ant -q -DinstallWs=gtk -DinstallOs=linux clean
+ ant -q -DinstallWs=motif -DinstallOs=linux clean
+ find ${S} -name '*.so' -exec rm -f {} \;
+ find ${S} -name '*.so.*' -exec rm -f {} \;
+ find ${S} -type f -name 'eclipse' -exec rm {} \;
+ rm -f eclipse
+
+ # Move around some source code that should have been handled by the build system
+ cd ${S}/"${gtk_swt_src_dir}" || die "Directory ${gtk_swt_src_dir} not found"
+ cp ${S}/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/* .
+ cp ${S}/plugins/org.eclipse.swt/Eclipse\ SWT\ Mozilla/common/library/* .
+ cp ${S}/plugins/org.eclipse.swt/Eclipse\ SWT\ Program/gnome/library/* .
+ cp ${S}/plugins/org.eclipse.swt/Eclipse\ SWT\ AWT/gtk/library/* .
+
+ if use gnome ; then
+ gnome_lib=`pkg-config --libs gnome-vfs-module-2.0 libgnome-2.0 libgnomeui-2.0 | sed -e "s:-pthread:-lpthread:" -e "s:-Wl,--export:--export:"`
+ fi
+
+ if ${use_gtk} ; then
+ gtk_lib=`pkg-config --libs gtk+-2.0 gthread-2.0 | sed -e "s:-pthread:-lpthread:" -e "s:-Wl,--export:--export:"`
+ atk_lib=`pkg-config --libs atk gtk+-2.0 | sed -e "s:-Wl,--export:--export:"`
+ fi
+
+ sed -e "s:/bluebird/teamswt/swt-builddir/IBMJava2-141:$JAVA_HOME:" \
+ -e "s:/bluebird/teamswt/swt-builddir/jdk1.5.0:$JAVA_HOME:" \
+ -e "s:/mozilla/mozilla/1.6/linux_gtk2/mozilla/dist:$MOZILLA_FIVE_HOME:" \
+ -e "s:/usr/lib/mozilla-1.6:$MOZILLA_FIVE_HOME:" \
+ -e "s:\`pkg-config --libs gtk+-2.0 gthread-2.0\`:${gtk_lib}:" \
+ -e "s:\`pkg-config --libs atk gtk+-2.0\`:${atk_lib}:" \
+ -e "s:\`pkg-config --libs gnome-vfs-module-2.0 libgnome-2.0 libgnomeui-2.0\`:${gnome_lib}:" \
+ -e "s:-I\$(JAVA_HOME)/include:-I\$(JAVA_HOME)/include -I\$(JAVA_HOME)/include/linux:" \
+ -e "s:-I\$(JAVA_HOME)\t:-I\$(JAVA_HOME)/include -I\$(JAVA_HOME)/include/linux:" \
+ -e "s:-L\$(MOZILLA_HOME)/lib -lembed_base_s:-L${mozilla_dir} -lgtkembedmoz:" \
+ -e "s:MOZILLACFLAGS = -O:MOZILLACFLAGS = -O -fPIC:" \
+ -e "s:\$(JAVA_HOME)/jre/bin:\$(JAVA_HOME)/jre/lib/i386:" \
+ -i make_gtk.mak
+
+ cd ${S}/"${motif_swt_src_dir}"
+ cp ${S}/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/* .
+ sed -e "s:/bluebird/teamswt/swt-builddir/IBMJava2-141:$JAVA_HOME:" \
+ -e "s:/bluebird/teamswt/swt-builddir/motif21:/usr/X11R6:" \
+ -e "s:/usr/lib/qt-3.1:/usr/qt/3:" \
+ -e "s:-lkdecore:-L\`kde-config --prefix\`/lib -lkdecore:" \
+ -e "s:-I/usr/include/kde:-I\`kde-config --prefix\`/include:" \
+ -e "s:-I\$(JAVA_HOME)/include:-I\$(JAVA_HOME)/include -I\$(JAVA_HOME)/include/linux:" \
+ -e "s:-I\$(JAVA_HOME)\t:-I\$(JAVA_HOME)/include -I\$(JAVA_HOME)/include/linux:" \
+ -e "s:-L\$(MOZILLA_HOME)/lib -lembed_base_s:-L\$(MOZILLA_HOME):" \
+ -e "s:-L\$(JAVA_HOME)/jre/bin:-L\$(JAVA_HOME)/jre/lib/i386:" \
+ -i make_linux.mak
+
+ cd ${S}
+ find -type f -name about.mappings -exec sed -e "s/@build@/Gentoo Linux ${PF}/" -i \{\} \;
+}
+
+build_gtk_frontend() {
+
+ einfo "Building gtk+ SWT"
+
+ # kludge to allow patches to applied at unpack, but correct compilation
+ if (( $ARCH=="amd64" )) ; then
+ gtk_swt_src_dir="plugins/org.eclipse.swt.gtk64/src/Eclipse SWT PI/gtk/library"
+ fi
+
+ # Build the eclipse gtk binary
+ cd ${S}/plugins/platform-launcher/library/gtk
+ case $ARCH in
+ sparc|x86|ppc)
+ tcsh -f build.csh -output eclipse-gtk -arch $ARCH || die "Failed to build eclipse-gtk"
+ ;;
+ amd64)
+ tcsh -f build64.csh -output eclipse-gtk -arch $ARCH || die "Failed to build eclipse-gtk"
+ ;;
+ esac
+
+
+
+ cd ${S}/"${gtk_swt_src_dir}"
+ case $ARCH in
+ sparc|x86|ppc)
+ bash ./build.sh make_swt || die "Failed to build platform-independent SWT support"
+ bash ./build.sh make_atk || die "Failed to build atk support"
+ ;;
+ amd64)
+ bash ./build64.sh make_swt || die "Failed to build platform-independent SWT support"
+ bash ./build64.sh make_atk || die "Failed to build atk support"
+ ;;
+ esac
+
+ if use gnome ; then
+ einfo "Building GNOME VFS support"
+ case $ARCH in
+ sparc|x86|ppc)
+ bash ./build.sh make_gnome || die "Failed to build GNOME VFS support"
+ ;;
+ amd64)
+ bash ./build64.sh make_gnome || die "Failed to build GNOME VFS support"
+ ;;
+ esac
+ fi
+
+ if use mozilla ; then
+ einfo "Building Mozilla component"
+ case $ARCH in
+ sparc|x86|ppc)
+ bash ./build.sh make_mozilla || die "Failed to build Mozilla support"
+ ;;
+ amd64)
+ bash ./build64.sh make_mozilla || die "Failed to build Mozilla support"
+ ;;
+ esac
+ fi
+
+ # move the *.so files to the right path so eclipse can find them
+ mkdir -p ${S}/"${gtk_swt_dest_dir}"
+ mv *.so ${S}/"${gtk_swt_dest_dir}"
+}
+
+build_motif_frontend() {
+
+ # Build eclipse motif binary
+ cd ${S}/plugins/platform-launcher/library/motif
+ tcsh -f build.csh -output eclipse-motif -arch $ARCH || die "Failed to build eclipse-motif"
+
+ cd ${S}/"${motif_swt_src_dir}"
+
+ make -f make_linux.mak make_swt || die "Failed to build Motif support"
+ if use kde ; then
+ make -f make_linux.mak make_kde || die "Failed to build KDE support"
+ fi
+
+ # move the *.so files to the right path so eclipse can find them
+ mkdir -p ${S}/"${motif_swt_dest_dir}"
+ mv *.so ${S}/"${motif_swt_dest_dir}"
+}
+
+src_compile() {
+
+ addwrite "/proc/self/maps"
+ addwrite "/proc/cpuinfo"
+ addwrite "/dev/random"
+
+ # Figure out correct boot classpath
+ if [ ! -z "`java-config --java-version | grep IBM`" ] ; then
+ # IBM JRE
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/core.jar:$(java-config --jdk-home)/jre/lib/xml.jar:$(java-config --jdk-home)/jre/lib/graphics.jar"
+ else
+ # Sun derived JREs (Blackdown, Sun)
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/rt.jar"
+ fi
+
+ export ANT_OPTS=-Xmx768m
+
+ einfo "Building resources.core plugin"
+ cd ${S}/${core_src_dir}
+ make JDK_INCLUDE="`java-config -O`/include -I`java-config -O`/include/linux" || die "Failed to build resource.core plugin"
+ mkdir -p ${S}/"${core_dest_dir}"
+ mv *.so ${S}/"${core_dest_dir}"
+
+ cd ${S}
+
+ # Build all java code -- default to gtk if neither of gtk, motif,
+ # kde are set
+ if ( ${use_gtk} || ! ( ${use_gtk} || ${use_motif} || use kde ) ); then
+ einfo "Building GTK+ frontend -- see compilelog.txt for details"
+ ant -q -q \
+ -buildfile build.xml \
+ -DinstallOs=linux \
+ -DinstallWs=gtk \
+ -DinstallArch=$ARCH \
+ ${ant_extra_opts} compile \
+ || die "Failed to compile java code (gtk+)"
+ fi
+ if ${use_motif} ; then
+ einfo "Building Motif frontend -- see compilelog.txt for details"
+ ant -q -q \
+ -buildfile build.xml \
+ -DcollPlace="eclipse-${SLOT}" \
+ -DinstallOs=linux \
+ -DinstallWs=motif \
+ -DinstallArch=$ARCH \
+ ${ant_extra_opts} compile \
+ || die "Failed to compile java code (Motif)"
+ fi
+
+ # Build selected frontends
+ ${use_gtk} && build_gtk_frontend
+
+ cd ${S}
+ # Build all java code -- default to gtk if neither of gtk, motif,
+ # kde are set
+ if ( ${use_gtk} || ! ( ${use_gtk} || ${use_motif} || use kde ) ); then
+ einfo "Installing GTK+ frontend -- see compilelog.txt for details"
+ ant -q -q \
+ -buildfile build.xml \
+ -DinstallOs=linux \
+ -DinstallWs=gtk \
+ -DinstallArch=$ARCH \
+ ${ant_extra_opts} install \
+ || die "Failed to compile java code (gtk+)"
+ fi
+ if ${use_motif} ; then
+ einfo "Installing Motif frontend -- see compilelog.txt for details"
+ ant -q -q \
+ -buildfile build.xml \
+ -DcollPlace="eclipse-${SLOT}" \
+ -DinstallOs=linux \
+ -DinstallWs=motif \
+ -DinstallArch=$ARCH \
+ ${ant_extra_opts} install \
+ || die "Failed to compile java code (Motif)"
+ fi
+
+ ${use_motif} && build_motif_frontend
+
+ cat ${FILESDIR}/eclipse-${SLOT}.desktop | \
+ sed -e "s/@PV@/${PV}/" \
+ > eclipse-${SLOT}.desktop
+}
+
+src_install() {
+ eclipse_dir="/usr/lib/eclipse-${SLOT}"
+
+ dodir /usr/lib
+
+ einfo "Installing features and plugins"
+ if ${use_gtk} ; then
+ [ -f result/linux-gtk-${ARCH}-sdk.zip ] || die "gtk zip bundle was not build properly!"
+ unzip -o -q result/linux-gtk-${ARCH}-sdk.zip -d ${D}/usr/lib
+ fi
+ if ${use_motif} ; then
+ [ -f result/linux-motif-${ARCH}-sdk.zip ] || die "motif zip bundle was not build properly!"
+ unzip -o -q result/linux-motif-${ARCH}-sdk.zip -d ${D}/usr/lib
+ fi
+
+ mv ${D}/usr/lib/eclipse ${D}/${eclipse_dir}
+
+ insinto ${eclipse_dir}
+
+ # Install launchers and native code
+ exeinto ${eclipse_dir}
+ if ${use_gtk} ; then
+ einfo "Installing eclipse-gtk binary"
+ doexe plugins/platform-launcher/library/gtk/eclipse-gtk \
+ || die "Failed to install eclipse-gtk"
+ fi
+ if ${use_motif} ; then
+ einfo "Installing eclipse-motif binary"
+ doexe plugins/platform-launcher/library/motif/eclipse-motif \
+ || die "Failed to install eclipse-motif"
+ fi
+
+ doins plugins/org.eclipse.platform/{startup.jar,splash.bmp}
+
+ # Install startup script
+ exeinto /usr/bin
+ doexe ${FILESDIR}/eclipse-${SLOT}
+
+ # Install GNOME .desktop file
+ if use gnome ; then
+ insinto /usr/share/gnome/apps/Development
+ doins eclipse-${SLOT}.desktop
+ fi
+
+ # Install KDE .desktop file
+ if use kde ; then
+ for x in /usr/kde/* ; do
+ insinto ${x}/share/applnk/Applications/
+ doins eclipse-${SLOT}.desktop
+ done
+ fi
+
+ doman ${FILESDIR}/eclipse.1
+}
diff --git a/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.0.1-r1 b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.0.1-r1
new file mode 100644
index 000000000000..df2af49b408d
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.0.1-r1
@@ -0,0 +1 @@
+MD5 c95561df899a47fc05261531ed0b9221 eclipse-sourceBuild-srcIncluded-3.0.1.zip 55618511