summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-11-11 16:09:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-11-11 16:09:34 +0000
commit8af3dec87c118165ae5febdf8a2886a133ed89a8 (patch)
treeed54afaca317a6722878fdbbe9624cdf9326d0c0 /dev-util
parentstable sparc, bug 287627 (diff)
downloadhistorical-8af3dec87c118165ae5febdf8a2886a133ed89a8.tar.gz
historical-8af3dec87c118165ae5febdf8a2886a133ed89a8.tar.bz2
historical-8af3dec87c118165ae5febdf8a2886a133ed89a8.zip
Version bump. Fixes bug 292615
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/stgit/ChangeLog8
-rw-r--r--dev-util/stgit/Manifest4
-rw-r--r--dev-util/stgit/stgit-0.15.ebuild74
3 files changed, 84 insertions, 2 deletions
diff --git a/dev-util/stgit/ChangeLog b/dev-util/stgit/ChangeLog
index 1413ffac2174..e1be71ee08cd 100644
--- a/dev-util/stgit/ChangeLog
+++ b/dev-util/stgit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/stgit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/ChangeLog,v 1.35 2009/08/21 20:32:37 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/ChangeLog,v 1.36 2009/11/11 16:09:34 hwoarang Exp $
+
+*stgit-0.15 (11 Nov 2009)
+
+ 11 Nov 2009; Markos Chandras <hwoarang@gentoo.org> +stgit-0.15.ebuild:
+ Version bump. Fixes bug 292615. Thanks to René 'Necoro' Neumann
+ <gentoo@necoro.eu> for the ebuilds and recommendations
21 Aug 2009; Jeremy Olexa <darkside@gentoo.org> -stgit-0.10.ebuild,
-stgit-0.14.1.ebuild:
diff --git a/dev-util/stgit/Manifest b/dev-util/stgit/Manifest
index 231517d2c6c6..b7f7b5329118 100644
--- a/dev-util/stgit/Manifest
+++ b/dev-util/stgit/Manifest
@@ -1,4 +1,6 @@
DIST stgit-0.14.3.tar.gz 227645 RMD160 5ed7ab18a3f98269c3fc29e4d1dd353171add7d9 SHA1 9ea2e859281f8fe3cbb7f2bd9fd83b9846923cbe SHA256 874fe750a8938d57ea777a0019f9fe50eb0ea408b71b618141a286d4cddfec8d
+DIST stgit-0.15.tar.gz 342320 RMD160 3779091ed8639c825f053c66031b4569a6ffbdea SHA1 8f18e3079014d907237aeffa6b851074422b7f27 SHA256 691fe26dc0c0691cb65fa2763c437eaafc28c107a4d64a03653ce613414ff84d
EBUILD stgit-0.14.3.ebuild 884 RMD160 c6131eabd2fc2a1a345090575d961b0fcba46f7b SHA1 e25a53125f08d135f3e59f37253d659b9ffb5ae6 SHA256 e5bc73e5219739552e6b7c2fca2cbaa091e10acf71585837801791ae03fa4908
-MISC ChangeLog 4529 RMD160 3105c03ada125c48e18c4fd7267bcf71cc525812 SHA1 aeeb8efd8cb0c512a841533a733c7ae4ac1a21d3 SHA256 8e2130338ee1a5dd701e4e49b1d64d2d6236b1be57ae7d1cc1c536741570ea9a
+EBUILD stgit-0.15.ebuild 1826 RMD160 88e697995cb376b6a85a30dd74c2289a3189707a SHA1 1c247caaf16e0992d416f1fcbee70403a82bfea5 SHA256 99bf35bd38623cef96d98d14cfb14f76b55c231838335a581c41338b97debcd6
+MISC ChangeLog 4754 RMD160 1ebbb0ac9bc986b8d35a336808d4eb146824fd72 SHA1 52e6f0197f6aeddc99057ec688fb7a35959331ab SHA256 46b361dfe6dd06f7df52a25ff47ae5eada24d4b0ccafc183241f278a209903d4
MISC metadata.xml 241 RMD160 dbd39e15096a9c09432225b4dee87bcadcb33907 SHA1 1beb1a93e4526085c26b282271027ad508b29059 SHA256 950a704ea9fcebef2e688e8bd6e0f0d292c967e246d58e4778b9955b1d615ab4
diff --git a/dev-util/stgit/stgit-0.15.ebuild b/dev-util/stgit/stgit-0.15.ebuild
new file mode 100644
index 000000000000..b41c75ef62fa
--- /dev/null
+++ b/dev-util/stgit/stgit-0.15.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/stgit-0.15.ebuild,v 1.1 2009/11/11 16:09:34 hwoarang Exp $
+
+EAPI="2"
+
+inherit distutils bash-completion
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-util/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future. Reference should be the online
+# man pages. (As of this writing, they use 8.2.7).
+DEPEND="$RDEPEND
+ doc? (
+ =app-text/asciidoc-8.2*
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup () {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # setup.cfg defaults to ~ ... delete it instead of sed'ing
+ rm setup.cfg
+ distutils_src_prepare
+}
+
+src_compile() {
+ # git throws errors if it cannot write its config file
+ # thus feed it a dummy one
+ touch gitconfig
+ export GIT_CONFIG="${S}/gitconfig"
+
+ # preparation stuff done in the makefile
+ emake build || die "emake build failed"
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+
+ # do not call normal 'emake' s.t. Gentoo's Python handling
+ # can do its work
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # do not use 'emake install-*' as the pathes are wrong
+ # and fixing them is more work than just using the following
+ doman Documentation/*.1 || die "doman failed"
+ dohtml Documentation/*.html || die "dohtml failed"
+ fi
+
+ dobashcompletion stgit-completion.bash ${PN}
+}