summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2008-01-27 10:19:43 +0000
committerFabian Groffen <grobian@gentoo.org>2008-01-27 10:19:43 +0000
commitb3ca69107b05012e865ea2a852d7bb3d7e1e7629 (patch)
tree92a8709d2867a05de0589633e734042adeba24ee /dev-util
parentVersion bump. (diff)
downloadhistorical-b3ca69107b05012e865ea2a852d7bb3d7e1e7629.tar.gz
historical-b3ca69107b05012e865ea2a852d7bb3d7e1e7629.tar.bz2
historical-b3ca69107b05012e865ea2a852d7bb3d7e1e7629.zip
Dropped ppc-macos keyword, see you in prefix
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/aegis/ChangeLog8
-rw-r--r--dev-util/aegis/aegis-4.19.ebuild25
-rw-r--r--dev-util/aegis/aegis-4.9.ebuild29
-rw-r--r--dev-util/cproto/ChangeLog7
-rw-r--r--dev-util/cproto/cproto-4.7e.ebuild6
5 files changed, 40 insertions, 35 deletions
diff --git a/dev-util/aegis/ChangeLog b/dev-util/aegis/ChangeLog
index 64dd16c8078f..bf81e3e9c6a9 100644
--- a/dev-util/aegis/ChangeLog
+++ b/dev-util/aegis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/aegis
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/ChangeLog,v 1.22 2007/12/25 14:02:21 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/ChangeLog,v 1.23 2008/01/27 10:15:36 grobian Exp $
+
+ 27 Jan 2008; Fabian Groffen <grobian@gentoo.org> aegis-4.9.ebuild,
+ aegis-4.19.ebuild:
+ Dropped ppc-macos keyword, see you in prefix
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing karltk from metadata.xml as per #200332. Assigning to
diff --git a/dev-util/aegis/aegis-4.19.ebuild b/dev-util/aegis/aegis-4.19.ebuild
index eb36bc0d9f6f..0c1793f56e9e 100644
--- a/dev-util/aegis/aegis-4.19.ebuild
+++ b/dev-util/aegis/aegis-4.19.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.19.ebuild,v 1.6 2007/01/14 02:40:58 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.19.ebuild,v 1.7 2008/01/27 10:15:36 grobian Exp $
IUSE="tk"
@@ -16,17 +16,16 @@ DEPEND="sys-libs/zlib
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~ppc ~ppc-macos sparc x86"
+KEYWORDS="~alpha ~ppc sparc x86"
src_compile() {
# By default aegis configure puts shareable read/write files (locks etc)
# in ${prefix}/com/aegis but the FHS says /var/lib/aegis can be shared.
- myconf="${myconf} --with-nlsdir=/usr/share/locale"
-
econf \
--sharedstatedir=/var/lib/aegis \
- ${myconf} || die "./configure failed"
+ --with-nlsdir=/usr/share/locale \
+ || die "./configure failed"
# Second ebuild causes redefined/undefined function errors
make clean
@@ -36,25 +35,25 @@ src_compile() {
}
src_install () {
- make RPM_BUILD_ROOT=${D} install || die
+ make RPM_BUILD_ROOT="${D}" install || die
# Alas gentoo appears to have no profile.d mechanism, so:
- rm ${D}/etc/profile.d/aegis.sh
- rm ${D}/etc/profile.d/aegis.csh
- rmdir ${D}/etc/profile.d
- rmdir ${D}/etc
+ rm "${D}"/etc/profile.d/aegis.sh
+ rm "${D}"/etc/profile.d/aegis.csh
+ rmdir "${D}"/etc/profile.d
+ rmdir "${D}"/etc
# OK so ${D}/var/lib/aegis gets UID=3, but for some
# reason so do the files under /usr/share, even though
# they are read-only.
- chown -R root:0 ${D}/usr/share
+ chown -R root:0 "${D}"/usr/share
dodoc lib/en/*
# Link to share dir so user has a chance of noticing it.
dosym /usr/share/aegis /usr/share/doc/${PF}/scripts
# Config file examples are documentation.
- mv ${D}/usr/share/aegis/config.example ${D}/usr/share/doc/${PF}/
+ mv "${D}"/usr/share/aegis/config.example "${D}"/usr/share/doc/${PF}/
dodoc LICENSE BUILDING MANIFEST README
}
diff --git a/dev-util/aegis/aegis-4.9.ebuild b/dev-util/aegis/aegis-4.9.ebuild
index 6db16f041c9a..8cf3ed03c23b 100644
--- a/dev-util/aegis/aegis-4.9.ebuild
+++ b/dev-util/aegis/aegis-4.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.9.ebuild,v 1.12 2007/04/09 15:37:42 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.9.ebuild,v 1.13 2008/01/27 10:15:36 grobian Exp $
IUSE="tk"
@@ -22,11 +22,10 @@ src_compile() {
# By default aegis configure puts shareable read/write files (locks etc)
# in ${prefix}/com/aegis but the FHS says /var/lib/aegis can be shared.
- myconf="${myconf} --with-nlsdir=/usr/share/locale"
-
econf \
--sharedstatedir=/var/lib/aegis \
- ${myconf} || die "./configure failed"
+ --with-nlsdir=/usr/share/locale \
+ || die "./configure failed"
# Second ebuild causes redefined/undefined function errors
make clean
@@ -36,23 +35,23 @@ src_compile() {
}
src_install () {
- make RPM_BUILD_ROOT=${D} install || die
+ make RPM_BUILD_ROOT="${D}" install || die
# Alas gentoo appears to have no profile.d mechanism, so:
- rm ${D}/etc/profile.d/aegis.sh
- rm ${D}/etc/profile.d/aegis.csh
- rmdir ${D}/etc/profile.d
- rmdir ${D}/etc
+ rm "${D}"/etc/profile.d/aegis.sh
+ rm "${D}"/etc/profile.d/aegis.csh
+ rmdir "${D}"/etc/profile.d
+ rmdir "${D}"/etc
# OK so ${D}/var/lib/aegis gets UID=3, but for some
# reason so do the files under /usr/share, even though
# they are read-only.
- chown -R root:root ${D}/usr/share
+ chown -R root:0 "${D}"/usr/share
# Remove duplicate documention etc.
- rm -r ${D}/usr/share/aegis/en
- rm -r ${D}/usr/share/aegis/de
- rm -r ${D}/usr/share/aegis/man1
+ rm -r "${D}"/usr/share/aegis/en
+ rm -r "${D}"/usr/share/aegis/de
+ rm -r "${D}"/usr/share/aegis/man1
# Leaving out the .dvi versions and junk.
dodoc lib/en/*.txt
@@ -62,7 +61,7 @@ src_install () {
dosym /usr/share/aegis /usr/share/doc/${PF}/scripts
# Config file examples are documentation.
- mv ${D}/usr/share/aegis/config.example ${D}/usr/share/doc/${PF}/
+ mv "${D}"/usr/share/aegis/config.example "${D}"/usr/share/doc/${PF}/
dodoc LICENSE BUILDING MANIFEST README
}
diff --git a/dev-util/cproto/ChangeLog b/dev-util/cproto/ChangeLog
index 80b5a52ba28d..f86b2c0cfadf 100644
--- a/dev-util/cproto/ChangeLog
+++ b/dev-util/cproto/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/cproto
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/ChangeLog,v 1.21 2007/03/19 12:26:44 kloeri Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/ChangeLog,v 1.22 2008/01/27 10:19:43 grobian Exp $
+
+ 27 Jan 2008; Fabian Groffen <grobian@gentoo.org> cproto-4.7e.ebuild:
+ Dropped ppc-macos keyword, see you in prefix
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove tcort from metadata.xml due to retirement.
diff --git a/dev-util/cproto/cproto-4.7e.ebuild b/dev-util/cproto/cproto-4.7e.ebuild
index fac7e9992c1a..7c80c0adeb7f 100644
--- a/dev-util/cproto/cproto-4.7e.ebuild
+++ b/dev-util/cproto/cproto-4.7e.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/cproto-4.7e.ebuild,v 1.6 2006/06/17 12:02:50 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cproto/cproto-4.7e.ebuild,v 1.7 2008/01/27 10:19:43 grobian Exp $
MY_PV="4_7e"
MY_P=${PN}-${MY_PV}
@@ -12,7 +12,7 @@ SRC_URI="ftp://invisible-island.net/cproto/${MY_P}.tgz"
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="alpha amd64 ppc ~ppc-macos x86"
+KEYWORDS="alpha amd64 ppc x86"
IUSE=""
src_install() {