summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-25 18:04:48 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-25 18:04:48 +0000
commitb3e76db96df9adfa350d7665ea43efcb072590bc (patch)
tree506a62c734e74a6709597031b486947005a535f2 /dev-util
parentMask USE=webm. (diff)
downloadhistorical-b3e76db96df9adfa350d7665ea43efcb072590bc.tar.gz
historical-b3e76db96df9adfa350d7665ea43efcb072590bc.tar.bz2
historical-b3e76db96df9adfa350d7665ea43efcb072590bc.zip
old
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/w32api/files/w32api-3.7-DESTDIR.patch33
-rw-r--r--dev-util/w32api/w32api-3.13.ebuild66
-rw-r--r--dev-util/w32api/w32api-3.15.ebuild60
3 files changed, 0 insertions, 159 deletions
diff --git a/dev-util/w32api/files/w32api-3.7-DESTDIR.patch b/dev-util/w32api/files/w32api-3.7-DESTDIR.patch
deleted file mode 100644
index de7645961a14..000000000000
--- a/dev-util/w32api/files/w32api-3.7-DESTDIR.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- w32api-3.7/lib/Makefile.in
-+++ w32api-3.7/lib/Makefile.in
-@@ -46,6 +46,8 @@
- inst_includedir:=$(includedir)
- inst_libdir:=$(libdir)
- endif
-+inst_includedir:=$(DESTDIR)$(inst_includedir)
-+inst_libdir:=$(DESTDIR)$(inst_libdir)
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
---- w32api-3.7/lib/directx/Makefile.in
-+++ w32api-3.7/lib/directx/Makefile.in
-@@ -42,6 +42,8 @@
- inst_includedir:=$(includedir)
- inst_libdir:=$(libdir)
- endif
-+inst_includedir:=$(DESTDIR)$(inst_includedir)
-+inst_libdir:=$(DESTDIR)$(inst_libdir)
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
---- w32api-3.7/lib/ddk/Makefile.in
-+++ w32api-3.7/lib/ddk/Makefile.in
-@@ -42,6 +42,8 @@
- inst_includedir:=$(includedir)/ddk
- inst_libdir:=$(libdir)
- endif
-+inst_includedir:=$(DESTDIR)$(inst_includedir)
-+inst_libdir:=$(DESTDIR)$(inst_libdir)
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
diff --git a/dev-util/w32api/w32api-3.13.ebuild b/dev-util/w32api/w32api-3.13.ebuild
deleted file mode 100644
index 99237fc03a20..000000000000
--- a/dev-util/w32api/w32api-3.13.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/w32api/w32api-3.13.ebuild,v 1.2 2009/01/10 23:24:13 vapier Exp $
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-MY_P="${P}-mingw32"
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.7-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf \
- --host=${CTARGET} \
- --prefix=/usr/${CTARGET}/usr \
- || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- emake install DESTDIR="${D}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
- fi
-}
diff --git a/dev-util/w32api/w32api-3.15.ebuild b/dev-util/w32api/w32api-3.15.ebuild
deleted file mode 100644
index 18269c8cc155..000000000000
--- a/dev-util/w32api/w32api-3.15.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/w32api/w32api-3.15.ebuild,v 1.1 2010/09/22 22:21:31 vapier Exp $
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-MY_P="${P}-1-mingw32"
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.lzma"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND="app-arch/xz-utils"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf \
- --host=${CTARGET} \
- --prefix=/usr/${CTARGET}/usr
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- emake install DESTDIR="${D}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
- fi
-}