summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-01 03:43:17 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-01 03:43:17 +0000
commitf8fc35d69da441df7a572c152bf595168252a157 (patch)
treecbfea4f18588a81b37608fc84a52bf24263cf7f9 /dev-util
parentremoved mask of old redhat-artwork. (diff)
downloadhistorical-f8fc35d69da441df7a572c152bf595168252a157.tar.gz
historical-f8fc35d69da441df7a572c152bf595168252a157.tar.bz2
historical-f8fc35d69da441df7a572c152bf595168252a157.zip
added support for static
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/ChangeLog9
-rw-r--r--dev-util/strace/files/digest-strace-4.4-r11
-rw-r--r--dev-util/strace/strace-4.4-r1.ebuild47
3 files changed, 54 insertions, 3 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 6e79f2d0fcb8..db8c5ced96f2 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-util/strace
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.8 2002/12/13 10:56:51 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.9 2003/01/01 03:43:17 vapier Exp $
+
+*strace-4.4-r1 (31 Dec 2002)
+
+ 31 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added support for static.
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*strace-4.4 (27 Apr 2002)
26 Sep 2002; Mike Frysinger <vapier@gentoo.org> :
diff --git a/dev-util/strace/files/digest-strace-4.4-r1 b/dev-util/strace/files/digest-strace-4.4-r1
new file mode 100644
index 000000000000..7d07987d9a58
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.4-r1
@@ -0,0 +1 @@
+MD5 7246ce73640760fa7e8357fd9ecf7af3 strace_4.4-1.tar.gz 398273
diff --git a/dev-util/strace/strace-4.4-r1.ebuild b/dev-util/strace/strace-4.4-r1.ebuild
new file mode 100644
index 000000000000..a0c991f6da80
--- /dev/null
+++ b/dev-util/strace/strace-4.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4-r1.ebuild,v 1.1 2003/01/01 03:43:17 vapier Exp $
+
+# NOTE: For some reason, upstream has changed the naming scheme
+# for the tarballs to something quite lame:
+# strace_version-revision.tar.gz
+# This makes it difficult for us to deal with, because portage
+# is supposed to glean the package version information from the
+# filename of the ebuild. Grr
+# Thus, *MAINTAINER*: change the *revision* in the SRC_URI below
+# by hand. Sorry, couldn't think of a better way.
+# - Jon Nelson, 27 Apr 2002
+
+DESCRIPTION="A usefull diagnostic, instructional, and debugging tool"
+SRC_URI="mirror://sourceforge/strace/strace_4.4-1.tar.gz"
+HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+IUSE="static"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf"
+
+src_compile() {
+ # Compile fails with -O3 on but works on x86, sparc untested
+ if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+ if [ -n "${CFLAGS}" ]; then
+ CFLAGS=`echo ${CFLAGS} | sed -e 's:-O3:-O2:'`
+ fi
+ fi
+
+ # configure is broken by default for sparc and possibly others, regen
+ # from configure.in
+ use static && export LDFLAGS="${LDFLAGS} -static"
+ autoconf
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ doman strace.1
+ dobin strace strace-graph
+ dodoc ChangeLog COPYRIGHT CREDITS NEWS PORTING README* TODO
+}